Google Play alert about OpenSSL

Get help using Construct 2

Post » Fri Jan 16, 2015 7:46 pm

FYI - I have been successfully updating my apps and submitting new apps to google play using the 'beta' tag in the latest XDK build. No issues building or submitting new or old projects to Google Play.

The SSL issue had nothing to do with updating SSL on your local machine - it was/is an XDK issue.
B
15
S
2
Posts: 229
Reputation: 1,353

Post » Fri Jan 16, 2015 9:03 pm

That's generally due to your images (build assets). Try removing some. They should not have special characters in the names.
Intel Corporation
B
5
S
2
Posts: 133
Reputation: 871

Post » Sat Jan 17, 2015 8:13 pm

imaffett wrote:That's generally due to your images (build assets). Try removing some. They should not have special characters in the names.

I renamed them, so I don't have any. The build still fails. I've also tried to remove all splashscreens and icons, but still build fails. :(
B
32
S
7
G
4
Posts: 398
Reputation: 4,591

Post » Sun Jan 18, 2015 9:14 am

I fixed it by updating the Crosswalk Build version from stable to 10.
http://shatter-box.com/knowledgebase/fix-openssl-issue/
Image Image iTunes: Match3 | Google Play: Match3
B
98
S
33
G
30
Posts: 1,118
Reputation: 27,793

Post » Mon Jan 19, 2015 3:49 pm

So, the OpenSSL alert is here again... As many of people here, I have temporarily bypassed it with installing new OpenSSL on my local machine, but - to be honest, it wasn't a real remedy. We have probably just suppressed it, until Google scanned apps again.
However, now I have a problem with Crosswalk 10 - my apps compiled with this version choke and crash on my tablet Orion 70l (quadcore, 1GHz Cortex A7). On previous version of Crosswalk (7, stable) they have worked ok. I guess that this will start a bunch of angry reviews for my apps, made by lower-end device users...
B
5
S
2
G
1
Posts: 16
Reputation: 532

Post » Mon Jan 19, 2015 3:53 pm

Message: volcank can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
@vladetam since I am at work today I will try out tonight building my games again with Crosswalk 10. Hope it goes on well.

I was going to ask a question. According to the tutorial below:

http://bit.ly/1yDsCBH

I just change the crosswalk version to 10 by typing it and do nothing else right?

Regards
B
19
S
6
Posts: 179
Reputation: 2,202

Post » Mon Jan 19, 2015 5:59 pm

@volcank
Yes - although I just type 'beta' which is currently version 10, and then recompile as usual. The problem with my apps, however, starts when I run them on my tablet (android 4.2). They become unresponsive too often... I don't know what's the reason behind this. With Crosswalk 7 they worked just fine. However, I must say that this machine is not too strong - on several other machines I see no such problems. That's not a comfort, though, since I know that many users do have weaker machines...
B
5
S
2
G
1
Posts: 16
Reputation: 532

Post » Mon Jan 19, 2015 9:48 pm

@vladetam You know I tried and my games are working just fine. Maybe you should try Cranberrygame's Phonegap WebviewPlus Plugin for better performance.
B
19
S
6
Posts: 179
Reputation: 2,202

Post » Wed Feb 18, 2015 3:35 am

One of my apps was having this issue but I deactivated the CocoonJS apk version and after a few hours the alert went away. So for me it wasn't an issue with my Crosswalk published build, but the Cocoonjs apk I had as a backup for older devices. Just wanted to mention that in case it helps anyone else.

edit: I take it back. Looks like the alert came back on Crosswalk apps that I haven't updated. I tried updating my openssl and using beta 10 on one of my apps and the alert hasn't come back on that one for a few days.
B
63
S
12
G
6
Posts: 456
Reputation: 8,981

Post » Thu Mar 12, 2015 6:03 am

I've the same problem, got this alert today, the only way i know to fix it is to build with crosswalk version 10 instead of version 7 and then the performance will be really bad ! any other solution ?
B
15
S
5
Posts: 192
Reputation: 1,514

PreviousNext

Return to How do I....?

Who is online

Users browsing this forum: Exabot [Bot], Lancifer, nahima and 11 guests