Google Play alert about OpenSSL

Get help using Construct 2

Post » Sun Mar 15, 2015 2:42 pm

any updates please ?
B
15
S
5
Posts: 192
Reputation: 1,514

Post » Fri May 08, 2015 8:26 pm

Hello!
Today, I opened Google Play Developer Console and saw this message (by the way, why I can't add an attachment to the post?):
Image
I'm building this app with Crosswalk 7.
What should I do? How to resolve this? @imaffett
What actually is OpenSSL? Why does my app use it?
B
32
S
7
G
4
Posts: 398
Reputation: 4,591

Post » Fri May 08, 2015 8:31 pm

Gotta love the OpenSSL Heartbleed.

It is used in forming https tunnels that secure your connection between each user and your server.

There should be somewhere in Google Play that allows you to address dependencies or injected libraries. You just have to find the openSSL one and point it to the latest library on the web.

I am not as familiar with Google Play, so I cannot tell you exactly how to do this, but here are some relevant pages from Google:
how-do-i-fix-this_t122692 <-- This one says to rebuild your app with Crosswalk 10 --
http://stackoverflow.com/questions/2419 ... ng-message
http://stackoverflow.com/questions/2756 ... of-openssl
http://discuss.cocos2d-x.org/t/resolved ... ever/14800
https://www.ravenheart.ca/home
I don't check the forums much anymore, but I will receive an email for PMs.

"Someone once told me I bite off more than I can chew...

I told them I would rather choke on greatness than nibble on mediocrity."
B
22
S
6
G
1
Posts: 1,418
Reputation: 4,830

Post » Sun May 10, 2015 6:03 pm

gumshoe2029 wrote:Gotta love the OpenSSL Heartbleed.

It is used in forming https tunnels that secure your connection between each user and your server.

There should be somewhere in Google Play that allows you to address dependencies or injected libraries. You just have to find the openSSL one and point it to the latest library on the web.

I am not as familiar with Google Play, so I cannot tell you exactly how to do this, but here are some relevant pages from Google:
how-do-i-fix-this_t122692 <-- This one says to rebuild your app with Crosswalk 10 --
http://stackoverflow.com/questions/2419 ... ng-message
http://stackoverflow.com/questions/2756 ... of-openssl
http://discuss.cocos2d-x.org/t/resolved ... ever/14800

Thanks, but if I try to build with CW10/11/12, I receive an error immediately: "The build failed. An error occurred while building the application. Verify your build assets are correct and try again." Only CW7 works ...
B
32
S
7
G
4
Posts: 398
Reputation: 4,591

Previous

Return to How do I....?

Who is online

Users browsing this forum: Yahoo [Bot] and 39 guests