Google Play, score submitted but leaderboard remains empty

Discussion and feedback on Construct 2

Post » Tue Dec 15, 2015 2:46 pm

Hi all -

First time I'm experimenting with mobile apps, ads, etc. and I decided to make a small game for Android.

So far it went quite well, and I have been able to get the game deployed to my phone (Android 5+, Cordova with or without Crosswalk via XDK) ; I also got AdMob and Google Play identification working quickly.

But now I'm hitting a problem with the Googe Play leaderboard ; I am able to submit scores (the "on score submit success" trigger does fire) but the leaderboard remains empty (request hi-scores > GooglePlay.HiScoreTotalCount = 0).

I found a few related discussions (e.g. viewtopic.php?f=147&t=165007&p=997552&hilit=google+play#p997552 ) and tried a few things, like disabling the score tampering security, but nothing helped.

I think all my authorisations are correct, I can log into Google Play through my browser or phone, but still can't get the leaderboard to update :-? Additionally it's a bit hard to submit a .capx for review, as this kind of feature only works if everything else is set up on the Google accounts...

At this stage I'm not too sure how to approach this... Surely I must be missing something ; any gut-feel or suggestion ?

Thanks !
Image
B
23
S
9
Posts: 237
Reputation: 2,207

Post » Mon Apr 25, 2016 11:17 am

It's now four months later and you have no answer. :( I am having the same issue. Everything works perfectly, as expected but the scores keep returning zero.
B
28
S
5
G
2
Posts: 41
Reputation: 2,445

Post » Mon Apr 25, 2016 12:39 pm

All I can say is, don't use the official plugin.

Buy these http://cranberrygame.github.io/request_ ... a_plugins/

before they double in price again. (note that not all of those plugins are working 100% correctly, and requesting an update will cost you 10$ min, the author gives next to no support too)
B
25
S
11
G
9
Posts: 136
Reputation: 6,657

Post » Wed Apr 27, 2016 8:51 pm

Hello,

I have the same problem, but I've noticed that in only fails when requesting public highscores, if you try it with social it return the scores.

I think is a bug from the Google Play plugin.
B
8
S
2
Posts: 42
Reputation: 649


Return to Construct 2 General

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests