Google Play services login issue - Cranberry game plugin

Get help using Construct 2

Post » Thu Jun 16, 2016 3:47 pm

@tamixx If you can do it then I'd appriciate that, i use cordova CLI too so it would help a lot. I've been trying to get this to work for a long time.
B
5
S
2
Posts: 124
Reputation: 872

Post » Thu Jun 16, 2016 5:24 pm

@tomhaiger i will record it tommorow
B
12
S
3
Posts: 19
Reputation: 778

Post » Tue Jun 21, 2016 12:08 pm

@tamixx Any luck with the video?
B
5
S
2
Posts: 124
Reputation: 872

Post » Tue Jun 21, 2016 4:41 pm

@tomhaiger sorry my sister is very sick she is at hospital so i be late i will record the video but sorry for the waiting time
B
12
S
3
Posts: 19
Reputation: 778

Post » Tue Jun 21, 2016 7:17 pm

@tamixx No need for apologies, it's fine. There's no rush so don't worry about it, i'm sure you have more important priorities right now.
B
5
S
2
Posts: 124
Reputation: 872

Post » Sun Jun 26, 2016 12:56 pm

Quick update. After deciding to try it again, I seem to have got this working even though i haven't changed anything from the last time. It seems to be a lot more consistant in logging in now.

I do still have a couple issues though, that i could get some help with:

1. If you choose not to sign in when the Google Play pop-up appears OR you sign out after you've signed in, i can't sign back in to Google Play services unless i exit the game and go back in and wait for the pop up. I have a button setup to login to Google Play if they aren't logged in already, this doesn't work as everytime i press it i get 'login failed' (This is custom message i put if it fails to login to Google Play). If i choose to sign in at the start when the pop-up appears, that button works as it's used to show leaderboard if the user is logged in, so it's only not working as it should when the user isn't signed in. (I hope this all made sense)

2. There is a delay in submitting scores to the online leaderboard. I have a button where you submit your score after its pressed, and a message will come up telling you that your score is submitted. Whenever i do this, this is a delay of a few seconds before the message shows up and the score is submitted.

Has anyone else encountered these issues and fixed them?
B
5
S
2
Posts: 124
Reputation: 872

Post » Sun Jul 17, 2016 1:58 pm

sorry for the video i'm verry verry busy..
i have the same problem when i use the plugin i can signin only at the first launch of the app..
for the score send the score of the user everytime so i can't verify if it have a delay do you wan't me to test if i can reproduce this bug?
B
12
S
3
Posts: 19
Reputation: 778

Previous

Return to How do I....?

Who is online

Users browsing this forum: JoshSenpai, kmsravindra, tetuan and 9 guests