Grammar/wording correction for "set visible".

Bugs will be moved here once resolved.

Post » Fri Jun 17, 2016 6:14 pm

Problem Description
"Set Visible" under appearance in the action menu should read as "Set Visibility". The current parameter for "Set Visible" correctly asks for the user to select "Visibility".

Attach a Capx
NA

Description of Capx
NA

Steps to Reproduce Bug
  • Step 1 Create an event for any object.
  • Step 2 Add an action for the object.
  • Step 3 Under "appearance", the action reads as "Set Visible".

Observed Result
NA

Expected Result
The action selection should read as "Set Visibility".

Affected Browsers
  • Chrome: (YES/NO)
  • FireFox: (YES/NO)
  • Internet Explorer: (YES/NO)

Operating System and Service Pack
Windows 7 service pack 1. I am running it on my Mac with Parallels.

Construct 2 Version ID
r229
B
42
S
20
G
6
Posts: 106
Reputation: 6,567

Post » Fri Jun 17, 2016 7:07 pm

Set invisibility?
I think visibility is a bit ambiguous as it implies multiple states of opacity.
Image ImageImage
B
172
S
50
G
183
Posts: 8,440
Reputation: 115,599

Post » Fri Jun 17, 2016 10:09 pm

:D
newt wrote:Set invisibility?
I think visibility is a bit ambiguous as it implies multiple states of opacity.

yeah..
B
13
S
5
G
4
Posts: 119
Reputation: 3,353

Post » Fri Jun 17, 2016 11:14 pm

The current parameter option does not appear as "invisibility".
B
42
S
20
G
6
Posts: 106
Reputation: 6,567

Post » Fri Jun 17, 2016 11:16 pm

The parameter for "set visible" is already calling itself "visibility: visible/invisible". In the same way the "set opacity" parameter is currently calling itself "opacity". If opacity were to follow the same form as "set visible" it would be called "set opaque".

You can apply it to sentence grammar:
Do you want to the object to be "visible"? Parameter should be: yes/no
How do you want to the "set visibility" state to appear? Parameter is currently: visible/invisible
B
42
S
20
G
6
Posts: 106
Reputation: 6,567

Post » Sat Jun 18, 2016 12:02 am

It's just splitting hairs.
If you were to go by what it really does you would say drawn, or not drawn.
While it has the advantage of not being seen, it also has the feature of not being rendered.

You're saying it should say "visibility: visibility/invisible", but that doesn't fit either.
If you were to keep visibility you need "visibility: visibility/invisibility"

"Visible: visible/invisible" makes more sense imo, and is correct grammatically, it's just not expected in its context.
"Drawn, not drawn" is probably confusing to a beginner.
Also: erased
Image ImageImage
B
172
S
50
G
183
Posts: 8,440
Reputation: 115,599

Post » Sat Jun 18, 2016 4:30 pm

All I am suggesting is wording uniformity. I know it's a small thing and a fine line of distinction.

newt wrote:
You're saying it should say "visibility: visibility/invisible", but that doesn't fit either.
If you were to keep visibility you need "visibility: visibility/invisibility"

This is not the wording I used. I think there is a misunderstanding here.

This is how it currently appears:
Add action>set VISIBLE>visibility: visible/invisible

This is my suggestion:
Add action>set VISIBILITY>visibility: visible/invisible
OR
Add action> set visible>VISIBLE: YES/NO
B
42
S
20
G
6
Posts: 106
Reputation: 6,567

Post » Sat Jun 18, 2016 6:45 pm

Visible: "Able to be seen"
Visibility: "The state of being able to see or be seen"

Source: Oxford English Dictionary.

Thus the editor is technically correct as it is and it would also be correct if it was changed to how your first suggestion is worded. Not a bug, just lexical semantics :).
A big fan of JavaScript.
B
76
S
20
G
76
Posts: 2,285
Reputation: 47,554

Post » Sat Jun 18, 2016 8:07 pm

Fair enough.

Thank you everyone for your time. :D
B
42
S
20
G
6
Posts: 106
Reputation: 6,567

Post » Mon Jun 20, 2016 3:22 pm

Closing as won't fix: while one way or the other may be technically correct according to English grammar, in programming some "inaccuracies" are actually quite common in order to refer more to the technical state rather than English prose. For example in programming it's common to have a function name like "SetIsVisible" (as in "set the 'is visible' flag"), even though "set is visible" is wrong or could mean something else. In C2 the action is meant in the context of "set visible [flag]" or "set [is] visible". I agree the contractions can look weird, but I won't rule out such style from C2, especially when action/condition names work best when they're as short as possible.
Scirra Founder
B
402
S
238
G
89
Posts: 24,644
Reputation: 196,095


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests