Graphic performance

Get help using Construct 2

Post » Tue Jul 31, 2012 3:31 pm

Hi. Here is the link to for the problem: https://www.dropbox.com/s/yxqklrpogbkprmb/game.capx

As you can see, when platformer moves on some rectangle or touches it, there is some very small white distance between them. Sometimes it is, sometimes it isn't.

How can it be fixed, so always, there would be perfectly no white distance and it would be absolutely together with the red rectangles.

Thanks in advice.

If it would be possible, then could some one correct that capx file and send it back?
B
4
Posts: 42
Reputation: 559

Post » Tue Jul 31, 2012 3:44 pm

with the black rectangles, not red. My mistake.

Is there any way, or it can't be done?
B
4
Posts: 42
Reputation: 559

Post » Tue Jul 31, 2012 7:47 pm

Turning 'pixel rounding' on in the projects properties seems to fix it.
B
28
S
8
G
1
Posts: 469
Reputation: 4,683

Post » Wed Aug 01, 2012 9:03 am

Yes, but then again there gets white distance between them.

Maybe c2 actaully can't get such good UI?
B
4
Posts: 42
Reputation: 559

Post » Wed Aug 01, 2012 9:21 am

check the sprites and polygons
B
45
S
15
G
6
Posts: 795
Reputation: 11,935

Post » Wed Aug 01, 2012 10:16 am

Searched forums and there was one quite simmilar to this one, but also didn't got answer.

All those methods don't give any use.
B
4
Posts: 42
Reputation: 559

Post » Wed Aug 01, 2012 2:46 pm

I haven't looked at your project.

But check the collision polygon on the elements. It's in the image editor for your sprites, under the "origin" button on the left.
B
22
S
7
G
3
Posts: 189
Reputation: 4,270

Post » Wed Aug 01, 2012 2:56 pm

Also tried that with no success.
B
4
Posts: 42
Reputation: 559

Post » Wed Aug 01, 2012 3:32 pm

@keepee

Hey, big thanks on it. After removing some things and using Your suggestion now all works perfect!

Great! :)
B
4
Posts: 42
Reputation: 559


Return to How do I....?

Who is online

Users browsing this forum: blackhornet and 5 guests