Group Activate - Deactivate not working >> file attached

Get help using Construct 2

Post » Fri May 20, 2016 6:16 am

I have tested group activate - deactivate is not working
i don't know why
this file
Image
B
63
S
39
G
42
Posts: 627
Reputation: 30,472

Post » Fri May 20, 2016 6:49 am

It is deactivating. You can prove that by touching "D" sprite before "S".

The issue is that you want to stop the rotation by deactivating the group, but that's not how you are going to achieve that. When you deactivate the group, you deactivate the events that are inside it. But once you touched "S" with the group active, you already set the rotation speed to 180º/s. In order for it to stop, create an event with set rotation speed to 0º/s.
B
22
S
4
G
3
Posts: 61
Reputation: 2,683

Post » Fri May 20, 2016 6:51 am

Works like it should

Image
If you touch "D" then you can't start the spin - only if you touch"A" after

"D" doesn't stop the spin. It only deactivates the group that initialize the rotation.

  • System > On start of layout | system > load game from slot "brain"
  • System > On load failed | system > scroll to obj_Forum
B
17
S
8
G
5
Posts: 340
Reputation: 4,707

Post » Fri May 20, 2016 7:01 am

yes
if i touch D before S then not rotating
and after touching A , then S rotating works
Thanks
actually i was testing that in my actual game activate - deactivate working or not
Now I know behaviors cannot be deactivate by this way
>>
if you have time please check y another post in which
I have another problem of adding point after watching advt video

look at this post too
Image
B
63
S
39
G
42
Posts: 627
Reputation: 30,472


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 3 guests