Guide: Fix Jank in r190+ Node-Webkit Export

Discussion and feedback on Construct 2

Post » Fri Dec 26, 2014 10:42 pm

@PSI
Actually, just to clarify, you aren't talking about the actual C2 IDE are you? Doesn't matter whether you use the 64 or 32 bit version of C2; all that matters is the version of the node-webkit exporter.
Don't lose your work. Backup your game with Dropbox.
B
44
S
10
G
10
Posts: 1,106
Reputation: 9,202

Post » Sat Dec 27, 2014 12:07 am

OK, got it. Thanks.
Image
B
20
S
4
Posts: 382
Reputation: 2,974

Post » Sat Dec 27, 2014 4:47 am

BTW - thanks for this guide - works great!
Image
B
20
S
4
Posts: 382
Reputation: 2,974

Post » Tue Jan 06, 2015 6:44 am

New build!

Node Webkit v0.11.5 (based on Chromium 38)

https://www.scirra.com/node-webkit
B
149
S
75
G
20
Posts: 1,791
Reputation: 22,695

Post » Tue Jan 06, 2015 8:34 am

alspal wrote:New build!

Node Webkit v0.11.5 (based on Chromium 38)

https://www.scirra.com/node-webkit


Any better? I'm thinking we won't see a significant improvement til chromium 39-40...but I'd love to be surprised. :)
Don't lose your work. Backup your game with Dropbox.
B
44
S
10
G
10
Posts: 1,106
Reputation: 9,202

Post » Tue Jan 06, 2015 11:15 am

Thanks for this guide, was a great help, seems like this improve performances (running on 32bits and not 64bits). I will try it on a bigger project to see if it helps. I have a really noob question though. Is it possible to export for the web with a different exporter (using base construct2 web exporter) ? (Since the jerkiness happens on chrome browser with the web exporter).Thanks
... "Je suis CHARLIE" ...
B
30
S
6
G
2
Posts: 43
Reputation: 2,075

Post » Tue Jan 06, 2015 3:35 pm

TiAm wrote:
alspal wrote:New build!

Node Webkit v0.11.5 (based on Chromium 38)

https://www.scirra.com/node-webkit


Any better? I'm thinking we won't see a significant improvement til chromium 39-40...but I'd love to be surprised. :)


I was running 11.5 It's better than previous, but I have way better performance from 10.5 after following this guide. This Node issue / C2 export issue is beyond annoying. It's getting to a point where I am seriously considering switching from C2 to something that exports to desktop properly. Nothing like working on your game and then out of no where.. janky stuttering. Try and fix, and realize that Node is the root cause. Pretty dampening to the workflow, motivation, and optimization efforts. :|
Image Image Image
B
61
S
19
G
6
Posts: 325
Reputation: 7,944

Post » Tue Jan 06, 2015 4:16 pm

facecjf wrote:
TiAm wrote:
alspal wrote:New build!

Node Webkit v0.11.5 (based on Chromium 38)

https://www.scirra.com/node-webkit


Any better? I'm thinking we won't see a significant improvement til chromium 39-40...but I'd love to be surprised. :)


I was running 11.5 It's better than previous, but I have way better performance from 10.5 after following this guide. This Node issue / C2 export issue is beyond annoying. It's getting to a point where I am seriously considering switching from C2 to something that exports to desktop properly. Nothing like working on your game and then out of no where.. janky stuttering. Try and fix, and realize that Node is the root cause. Pretty dampening to the workflow, motivation, and optimization efforts. :|


I was feeling the same Facecjf. It's sad, and i don't think Construct2 can do anything about it (and we are not talking about any kind of bad optimisation, since it's the same with super basic tests).
I'm annoyed too but my project was still in the prototype phase and not too advanced so ...
But for those how had games running smoothly before, it must be a real down.
... "Je suis CHARLIE" ...
B
30
S
6
G
2
Posts: 43
Reputation: 2,075

Post » Tue Jan 06, 2015 4:33 pm

Softloulou wrote:I was feeling the same Facecjf. It's sad, and i don't think Construct2 can do anything about it (and we are not talking about any kind of bad optimisation, since it's the same with super basic tests).
I'm annoyed too but my project was still in the prototype phase and not too advanced so ...
But for those how had games running smoothly before, it must be a real down.


It is and it isn't. It's the nature of constructs reliance on 3rd party wrappers. I've found that what doesn't work now... will work in about 4 months. :lol:
Don't get me wrong, C2 is amazing for 2D game development, with great update cycles, stability, and features. I just wish desktop publishing was better and not reliant on Node.
Image Image Image
B
61
S
19
G
6
Posts: 325
Reputation: 7,944

Post » Tue Jan 06, 2015 6:38 pm

For information purposes:

I tested previews and exports with the following versions of C2 and NW.
(r190, r192, and r193) + NW 11.5 = still stuttering.
I reverted back to NW 10.5 (Win 32bit) and it's smooth again.

Hardware Specs:
xeon 3.5ghz
32 gb ram
solid states
nvidia gtx650 ti

These are just my findings, though I am curious of others results as well
Image Image Image
B
61
S
19
G
6
Posts: 325
Reputation: 7,944

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 2 guests