Has anyone ever had a similar problem?

Discussion and feedback on Construct 2

Post » Sat Feb 18, 2017 3:00 pm

So this is the 2nd time this happend to me, I import images from a sprite strip,
edit them a bit and change the origin and stuff like that and everything works just fine ... but then suddenly, i think it happens after i save the project as a .capx, the different graphics of all the animation frames all change to the same graphic... well not all, some stay correct.
The first time I imported a ton of animation frames of the main character and after i saved the project 2/3 of all animation frames changed to 2 alternating graphics.

Now this 2nd time it happened with a set of weapons, it even still shows the correct weapon sprites for the ones that are placed in the layout but they are streched
I marked the important parts in the image
-edit- Here is a gif of the problem -edit-

Here you can see that frame 0 is correct frame 1 is also correct and is the frame that gets repeated over n over till suddenly frame 19 is correct again ?!?!?
Here are all the weapon sprites placed in the layout

I have really no idea why this is happening and how to reproduce this issue
but its very frustrating especially when it happend with the main character of our game and i had to replace 120 animationframes. :evil:
Last edited by EpicPixel on Sat Feb 18, 2017 5:24 pm, edited 1 time in total.
B
68
S
28
G
7
Posts: 85
Reputation: 7,496

Post » Sat Feb 18, 2017 3:29 pm

Just a few guesses:

If you use the select box to edit but don't click on the edit screen to set that box it will not save the edit and will revert back to image before edited.


If you accidentally click a apply to whole animation or apply to all animations while in paste mode or changing the size or setting the collisions that will apply to all animations in a frame and all animations in the entire sprite.

You won't see that happened until you close the sprite and play it or go back and look at the sprite again and if you save it that is why you would see sprites not as you wanted them.



I noticed in the first pic you do not have the sprite cropped and if you do not crop and then set that sprite to a specific size in your events it may appear blurry or stretched.

Good idea to crop each image as you edit.
Banned User
B
23
S
6
G
58
Posts: 1,229
Reputation: 34,540

Post » Sat Feb 18, 2017 3:44 pm

@lamar thanks for the reply but i know these things and i am 100% sure this is not what happened.
It would also not explain why the sprite placed in the layout shows a different image then the one in the sprite editor.
I can close and reopen the sprite editor and it still shows a different image in the layout then in the editor.
B
68
S
28
G
7
Posts: 85
Reputation: 7,496

Post » Sat Feb 18, 2017 3:56 pm

EpicPixel wrote:@lamar thanks for the reply but i know these things and i am 100% sure this is not what happened.
It would also not explain why the sprite placed in the layout shows a different image then the one in the sprite editor.
I can close and reopen the sprite editor and it still shows a different image in the layout then in the editor.


OK then.

The sprite shown in the layout will be the first frame of the first animation when you close the editor unless you tell it to change in an event or in the settings for that sprite. I would check your settings.

Best of luck!
Banned User
B
23
S
6
G
58
Posts: 1,229
Reputation: 34,540

Post » Sat Feb 18, 2017 3:56 pm

Ok i made a gif, maybe that shows better what is going on
GIF
B
68
S
28
G
7
Posts: 85
Reputation: 7,496

Post » Sat Feb 18, 2017 4:11 pm

EpicPixel wrote:Ok i made a gif, maybe that shows better what is going on
GIF


I checked it on my own sprite and seems to work fine but I do not use Default and all sprites animations are named.

You can try changing that to a named animation and see if it still does it?

I would clear that sprite animation frame and reload the image you want and see if it changes in the layout to test it.
Banned User
B
23
S
6
G
58
Posts: 1,229
Reputation: 34,540


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 9 guests