Having a problem with my platforming.

Get help using Construct 2

Post » Fri May 09, 2014 4:38 am

And to help, I HAVE A YOUTUBE VIDEO. WOO.

https://www.youtube.com/watch?v=l74yDxUzI_Y

The annotations show what I'm having problems with, mainly just keeping the animations right. I have another one, more of a testing ground, and for some reason, when he jumps and lands and whatnot in that one, it works right. However, I have it set on the same EXACT BLOODY SETTING in the one I'm working on now, and it's not working right!

Enclosed is a copy/paste of my event sheet.

Image
B
6
Posts: 21
Reputation: 268

Post » Fri May 09, 2014 4:41 am

i think the sinking problem is cuz of the animation , and i'd use when is not moving (on moved inverted) set to default and when moving walk , hope it helps :)
B
7
S
1
Posts: 18
Reputation: 447

Post » Fri May 09, 2014 5:58 am

on moved walk
on stopped idle
on jumped jump
on landed subevent
is moving walk
is not moving idle
B
15
S
6
G
4
Posts: 277
Reputation: 3,948

Post » Fri May 09, 2014 8:48 am

You can check construct 2 full platform tutorial on youtube and reddit and there also full capx to download for the platform game included animation's event's.
B
60
S
10
G
10
Posts: 1,013
Reputation: 9,155

Post » Fri May 09, 2014 7:30 pm

Roccinio wrote:on moved walk
on stopped idle
on jumped jump
on landed subevent
is moving walk
is not moving idle


I tried that, and it won't let me do an "On Landed" subevent.

What is looks like it's doing is whenever it moves, it jumps a little. o_O
B
6
Posts: 21
Reputation: 268

Post » Fri May 09, 2014 10:00 pm

no no! :)
on landed
subevent
is moving-------------------------------- walk
is not moving---------------------------- idle
B
15
S
6
G
4
Posts: 277
Reputation: 3,948

Post » Sat May 10, 2014 12:58 am

Also, the sinking part is due to the collision polygons, and/or the origin point of the Player Sprite changing over time, at every frame. You should use a different, invisible sprite with the platform behavior, that has a simple rectangular collision polygon, and pin the Player Sprite (with the graphics and the animations) onto it. That way you will have cleaner and more efficient collisions.
composer - multimedia artist
www.eli0s.com/en/
B
69
S
26
G
5
Posts: 1,146
Reputation: 9,829

Post » Sat May 10, 2014 2:27 am

Well, I put in a fresh animation sprite, and it works now without sinking.
B
6
Posts: 21
Reputation: 268

Post » Sat May 10, 2014 3:52 pm

Great!:)
composer - multimedia artist
www.eli0s.com/en/
B
69
S
26
G
5
Posts: 1,146
Reputation: 9,829


Return to How do I....?

Who is online

Users browsing this forum: Anonnymitet, atmas, tarek2 and 26 guests