Having an issue with gamepad functionality.

Get help using Construct 2

Post » Wed Jul 30, 2014 8:11 pm

Hey all, I posted this in bugs a few days ago and haven't gotten a reply yet. I'm hoping that someone here can help. I'm just going to copy/paste my original post here:

Problem Description

There seems to be an issue with assigning actions to the Right Trigger using a gamepad.

I tried to set a Parry/Block animation to the right trigger of a gamepad, and when I ran the layout, nothing happened.

I then noticed that when I pressed up on the Right analog stick, the action I assigned to to right trigger occurred.

I switched the even from "On button pressed" to "while button is down," and the same issue persisted.

I wondered if it was my gamepad, so I switched the event from "Gamepad 0" to "Gamepad 1," while I had a second gamepad plugged in and functioning, and the right trigger did nothing on the second gamepad.

I also tried switching the event to trigger on the left triggers of each gamepad, and nothing occurred, however when I switched the event to a button (y or b) or the left and right bumpers, the ParryBlock animations were triggered properly.

Attach a Capx

This is the Capx for my project: https://www.dropbox.com/s/szjxvd9fohbx0 ... 20Bug.capx

Description of Capx

I only have one event sheet, and the specific event is number 24, under group "Player1Controls" I starred the specific event.

I'm creating a beat 'em up, and I want the right trigger to initiate a Parry to Block animation. for each character. I was starting to assign the animation itself to the first player when I noticed it wasn't responding.

Steps to Reproduce Bug

Start computer with gamepads plugged in.
Open Capx.
Run Layout
Press Right Trigger


Observed Result

Nothing happened, when it should initiate animation "ParryBlock" for object "Greatsword" With variable value "Instance" the same as Object "PlayerBox1."
Each of the other assigned actions to the gamepad are functioning.

Expected Result

Player1 (blue) should perform animation "ParryBlock."

Construct 2 Version ID

Release 173 (64-bit), running Windows 8.
B
9
S
2
Posts: 37
Reputation: 739

Post » Fri Aug 01, 2014 1:41 am

You didn't say which browser in your bug report. If it's Firefox, I've found the buttons don't map correctly. Try Chrome. I switched from Y to X axis in events 17 & 19, and the game pad moves correctly and RT works.
ImageImageImage
B
71
S
21
G
221
Posts: 3,649
Reputation: 124,227

Post » Fri Aug 01, 2014 11:07 pm

Crap. I am using Firefox. Is that something we can expect a fix for, you think, or is that just an inherent flaw in the compatibility?
B
9
S
2
Posts: 37
Reputation: 739

Post » Sat Aug 02, 2014 1:00 am

No idea. There's a cool test page here though, so you can see the behaviours. Has nothing to do with C2, so we know it's not on C2's end.

http://www.html5rocks.com/en/tutorials/ ... ester.html
ImageImageImage
B
71
S
21
G
221
Posts: 3,649
Reputation: 124,227


Return to How do I....?

Who is online

Users browsing this forum: Demkamen and 13 guests