Having problems with enemy movement!

Get help using Construct 2

Post » Mon May 27, 2013 5:29 am

Hi everybody! I am having problems making enemies move using platform simulate movement. All of my enemies before were just using a bullet behavior, but I wanted to make them jump so I am trying to switch. I have their events set up just like in the "How to make a platform game" guide. But when my enemy hits an edge marker to flip direction he glitches out flashing rapidly and teleporting to both edge markers nonstop! So I can't even get him to move left and right let alone jump(which I would like to get set up after I can find a fix for this). Does anyone have any ideas for me that could help him stop bugging out? Anything would be great, thanks! This is the page I modeled my events from: How to make a platform game33miles2013-05-30 23:43:07
B
8
Posts: 42
Reputation: 1,009

Post » Thu May 30, 2013 11:44 pm

Any thoughts from you expert guys?
B
8
Posts: 42
Reputation: 1,009

Post » Fri May 31, 2013 12:20 am

Are you changing direction via simulate platform left/right, or are you setting the X/Y coordinates? ALso check your animation frames and ensure you are not having a different shaped collision polygon on each frame of your animation.
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,428

Post » Fri May 31, 2013 12:32 am

Thanks for responding BluePhaze! I am changing directions with simulate platform left and right. And my sprite only has 1 frame, his collision is a bounding box. Please let me know what you think I should do, thanks!
B
8
Posts: 42
Reputation: 1,009

Post » Fri May 31, 2013 1:08 am

you might want to post your capx if you want more specific help.
B
16
S
3
Posts: 24
Reputation: 859


Return to How do I....?

Who is online

Users browsing this forum: Ethan, makkancs, Marxally, Naightwolf, pierre244 and 15 guests