Heights not correct? Also positions seem bad?

For questions about using Classic.

Post » Sun Feb 08, 2009 11:57 pm

Basically my layer is set to 100 height and when it loads i have the window object set the height of the window to 100 yet they are different sizes?

Screenshot1: http://i43.photobucket.com/albums/e397/clericvash/1.gif
Screenshot2: http://i43.photobucket.com/albums/e397/ ... sh/2-1.gif

As you can see when i run it, it is a different size :shock:

Edit > Did another test, the window object deffo doesn't set height and width correctly!!
It seems to count the title bar into to height as well, shouldn't it only count the layouts size?

Also positioning seems off here check this one:
Screenshot: http://i43.photobucket.com/albums/e397/ ... rd02-3.gif
There is a gap between buttons and listbox, when there should be none.
B
3
S
2
G
5
Posts: 301
Reputation: 2,302

Post » Mon Feb 09, 2009 12:14 am

Just use the "Set display resolution" action under the System object. That will change the window to the correct size.
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Mon Feb 09, 2009 12:33 am

Seems to do nothing at all if i try that.
B
3
S
2
G
5
Posts: 301
Reputation: 2,302

Post » Mon Feb 09, 2009 12:45 am

[quote="liamdawe":sw7b0r6f]Seems to do nothing at all if i try that.[/quote:sw7b0r6f]

Huh, that's odd. It worked for me. :? What about this CAP?
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Mon Feb 09, 2009 1:58 am

'Set window size' includes the window titlebar, border etc. so it'll come out too small when you set the window size to the same as the layout size. As linkman said, set display resolution ought to work.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Mon Feb 09, 2009 4:02 pm

That cap seems to not be there?

I have tried on start of layout and on load, changing resolution and layout size, neither seem to do anything.
B
3
S
2
G
5
Posts: 301
Reputation: 2,302


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 0 guests