Help about setting web font

Discussion and feedback on Construct 2

Post » Sun Apr 07, 2013 2:30 pm

Hello,

I'm setting the font face well, it works fine. I followed that tutorial

https://www.scirra.com/tutorials/237/how-to-use-your-own-web-fonts

Here is my problem ,

I'm adding set font face at on start of layout; but when i testing it, it starts with default font and after x milliseconds it turns to my web font. I don't want to see that "shaking", i found that some people are changing visibility and delaying. However I cant know that delaying time. So is there any way to know if the web font changing is finished?

Second question is, i don't want to set every text manually , is there any way to set it globally to every text object.

Maybe the third question, i didn't make it to set all text objects' fonts at the loading screen. Am I have to do it at the every layouts starting?

B
7
Posts: 8
Reputation: 941

Post » Mon Apr 08, 2013 1:39 pm

To answer your second question, you can create a family group and place all your text objects in there, then apply set font face to the family.
You need to set the text at the start of each layout.
B
31
S
11
G
7
Posts: 197
Reputation: 6,682

Post » Mon Apr 08, 2013 3:05 pm

I'm afraid you can't detect when a web font has finished loading, browsers don't yet provide this feature. Workarounds are discussed in this tutorial though.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,610


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests