[HELP] Admob object - FPS decrease fixable?

Discussion and feedback on Construct 2

Post » Sat Apr 04, 2015 11:52 am

Hi,

my current project is running smoothly at 60FPS, on C2 preview as well as on my smartphone. The moment I add the admob object to my project, I encounter a drop of FPS in the fully exported app and sometimes a little lag (while in C2 preview everything still works fine). This is the case even when my smartphone is offline and can't even receive any ads, which makes me wonder why this happens.

I am using Intel XDK to export to android via crosswalk. A few other posts stated that the FPS drop is caused by the fact that in admob, text ads are enabled. So i disabled them, showing only image ads. It didn't change anything.

Is there a way to avoid the FPS drop? It's really a pity because I dedicated so much work in making the game run smoothly.
B
13
S
3
G
1
Posts: 91
Reputation: 1,477

Post » Sat Apr 04, 2015 12:17 pm

you can call @imaffett if it is Crosswalk issue
or @Ashley if it is Construct 2 issue
B
18
S
7
G
1
Posts: 783
Reputation: 4,237

Post » Mon Apr 06, 2015 11:59 am

@CreativeMind - can you let me know the following

Device Model
Device OS
Crosswalk Version
Link to test it if possible (you can send me a link via PM to the APK)
Intel Corporation
B
5
S
2
Posts: 133
Reputation: 871

Post » Mon Apr 06, 2015 1:14 pm

Crosswalk 10 is bad enough but with admob banners the lag and poor framerate makes anything unplayable (tested on Note 3 and S4).
So I have currently disabled banner ads.
B
7
S
1
Posts: 41
Reputation: 572

Post » Tue Apr 07, 2015 9:20 pm

@immafett

I'm using a Samsung Galaxy S2 with Android Version 4.1.2. First, I used Crosswalk 10 to build.

Now I decided (just like mercedescolomar) to disable banner ads and build with Crosswalk 7 and now the performance is good. I guess a link to my apk won't help you, because I didn't do anything fancy in 2 besides preloading the banner and then showing it. But thanks anyway!
B
13
S
3
G
1
Posts: 91
Reputation: 1,477

Post » Mon Apr 13, 2015 3:49 pm

@CreativeMind Agree Admob banners make the game jittery/laggy especially on startup. It does settle down after a while and things run smoothly, but it can be 10-15 seconds.
I also find the 'disable text ads' suggestion makes no difference. I've tried disable images as well.. no improvement.
B
24
S
7
G
1
Posts: 186
Reputation: 2,716

Post » Tue Jun 16, 2015 7:16 am

My game has the same issue. If i turned off admod, everythings went smoothly. And then turn on the admob, while the ad is loading, some lags happened about 1-10 seconds . After the ad is showed and closed, the lags happened all the time, it caused my game crashed. I have searched a solution for 1 week, but no clue. This issue was still not resolved from year 2013 till to now .... It made me have to turn off the admob in my game = no money >.<
P/S : I'm using Interstitial only ads and this bug is only happened in low-end Android devices. Some my testing mobile phones have these bug : Dragon Touch Y88, Samsung Galaxy Trend Plus, MeMO PAD ...
Can anyone share me the solution for this please ? My email : [email protected] .Thank you for any advices.
B
13
S
1
Posts: 96
Reputation: 881

Post » Tue Jun 23, 2015 7:24 am

any solutions guys ? i have same problems with admob and crosswalk
B
45
S
16
G
8
Posts: 792
Reputation: 8,306

Post » Tue Jun 23, 2015 7:58 am

@qngnht
@matrixreal

Google is a big company. They have hundreds of programmers. That's why @Ashley has a strong faith in Google.

They also own AdMob.

So sooner or later they will fix this bug. Maybe.
B
18
S
7
G
1
Posts: 783
Reputation: 4,237

Post » Tue Jun 30, 2015 9:37 pm

Same here:
Galaxy Tab 4 + Admob Banner ads + Crosswalk = Crash
Frame rate drops from 57 - 60 to around 30 fps

Remove banner ads (cranberry) and app runs at full pelt.

https://www.scirra.com/forum/viewtopic.php?f=147&t=149045
B
9
S
3
Posts: 146
Reputation: 1,150

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 6 guests