Help: Ads not showing up and Intel XDK

Discuss game development design and post your game ideas

Post » Sat Jul 15, 2017 11:21 pm


So this has been sort of a nightmare...

I am trying to get ads working in my game, but when I run the game on a test device nothing shows up.

I have done the following:

1. Added Admob object, created account and entered the relevant ad ID's in C2 = OK

2. On laylout loaded, preload ad, on recieved show etc. = OK

3. Exported as Cordova, with correct settings (no script misc) = OK

4. Imported the project into Intel XDK, added the plugin (cordova-plugin-admob-free) = OK

5. Build: So they have disconinued the cloud build services, meaning I have to export as a zip file. = Should be OK?

6. Upload the to Phonegap build, and installed app.

Based on all the documentation I have read nothing should be wrong here, yet no ads are showing in the app as if the code was never implemented, anyone who could help out?
Posts: 3
Reputation: 181

Post » Sun Jul 16, 2017 7:30 am

On Android or on iOS?
Posts: 143
Reputation: 7,096

Post » Mon Jul 17, 2017 12:35 am

Hi! I made a game and I had the same problem, I investigated and I found that the newest versions of Intel XDK have this problem, what we have to do (I have not solved this problem yet) is install an older version of the program!
I hope this helps a bit, and sorry for my bad English :lol: :lol:
Posts: 1
Reputation: 177

Post » Mon Jul 17, 2017 4:45 pm

Android, I got it working!

So it turns out it was all done correct, but there was a bug in adsense where no ads would show until I had added payment information, but payment information was not possible to add before hitting the payment minimum. Luckily google support team was quick to fix, and ads are now showing!
Posts: 3
Reputation: 181

Return to Game Development, Design & Ideas

Who is online

Users browsing this forum: No registered users and 0 guests