Help: Auto-runner template

Get help using Construct 2

Post » Mon Mar 25, 2013 6:41 am

I'm currently making games which is using Auto-Runner template, but why my character is shaking and occurs a 'lag' when it's on the edge of the cliff.

Can someone help me?

Here is my capx.

https://dl.dropbox.com/s/muvdq8cvi1b78yu/Runner.capx?token_hash=AAHKdDgo7NcY2h_dl-q8o4jbCyHBfR_OelVgchkkB-xZrg&dl=1

Thanks in advance.
B
4
Posts: 6
Reputation: 667

Post » Mon Mar 25, 2013 2:13 pm

bumping

one more question, how to make the gap between blocks is smaller and the block height is shorter?ariaenggar2013-03-25 14:48:45
B
4
Posts: 6
Reputation: 667

Post » Tue Mar 26, 2013 12:49 am

Most likely you are hitting the seems in the tiles and the issue is possibly related to the fact that you are not using a separate collision sprite pinned to your player sprite. If your player has it's own default collision polygon the shape may be changing during animation of the run and that will cause a lot of odd collision issues. Check the platformer tutorials as they deal with creating a separate collision sprite and pinning it to the player.
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,418

Post » Tue Mar 26, 2013 2:21 am

@BLuePhaze, it works, thank you very much.

My second question is how to make the gap between blocks is smaller and the block height is shorter?
B
4
Posts: 6
Reputation: 667


Return to How do I....?

Who is online

Users browsing this forum: Megavolt, mnashwan, shinkan, stylie1 and 17 guests