Help: Character not moving

Get help using Construct 2

Post » Sat Feb 28, 2015 3:37 pm

Hi,

This may sound like a nooby question but I've battled trying to get my character to move on a game I'm working on.
I've got a procedurally generated map and it spawns a movable character in a room except the character isn't movable. I've tried changing the layers of which things are on but to no avail.

If you want to help, reply letting me know and I'll send you a link to the capx via PM.
B
8
S
1
G
1
Posts: 3
Reputation: 502

Post » Sat Feb 28, 2015 3:46 pm

I think I can help you, send me PM :P
B
73
S
21
G
10
Posts: 641
Reputation: 9,798

Post » Sat Feb 28, 2015 3:51 pm

Where can I get the Clay.io plugin?
B
73
S
21
G
10
Posts: 641
Reputation: 9,798

Post » Sat Feb 28, 2015 3:57 pm

Find it at http://clay.io/docs/construct2

It's not used in this project, I don't know why I added it. :P
I have removed it from the project so you can re-download it from the link I sent you in the PM.
B
8
S
1
G
1
Posts: 3
Reputation: 502

Post » Sat Feb 28, 2015 4:09 pm

Well, I don't undestand everything
But I'm pretty sure that you are creating objects that collide, I mean the player is created inside a wall or something
That should be why it's not moving, I guess
B
73
S
21
G
10
Posts: 641
Reputation: 9,798

Post » Sat Feb 28, 2015 4:26 pm

HA!

I just found the problem my friend!
You should set the position of the player just the very first time, otherwise it will be always in the same position

Image

:P
B
73
S
21
G
10
Posts: 641
Reputation: 9,798

Post » Sat Feb 28, 2015 4:33 pm

Thank you soo much! :D
You're awesome!
B
8
S
1
G
1
Posts: 3
Reputation: 502


Return to How do I....?

Who is online

Users browsing this forum: frayt, newt and 8 guests