[Help] HTML5 export breaks my game

Discussion and feedback on Construct 2

Post » Thu May 15, 2014 5:16 pm

Hey,

I am using Construct 2 to create a game for my ICT project however when previewing the game through the preview button in Construct the game looks fine. However, when exporting it to HTML5 it makes all the moving sprites half the size which messes up the collision detection etc. I have exported with both minified and compressed pngs as well as not minified and uncompressed pngs and the bug seems to still be there. Is there something I haven't enabled or is this a bug with Construct 2?

If you would like see the problem I am facing then please go here to see the exported version of the game: tomerbe.meximas.com/demos/mr-blob/ If you then click play and level one you will see the problem I have.

Thank you in advanced for any help and I hope there is a fix.

-- Tom E
B
3
Posts: 2
Reputation: 179

Post » Thu May 15, 2014 5:19 pm

You don't have enough rep to post a link so it has been removed.
B
40
S
12
G
11
Posts: 331
Reputation: 7,752

Post » Thu May 15, 2014 5:38 pm

New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
294
S
117
G
96
Posts: 7,310
Reputation: 71,084

Post » Fri May 16, 2014 10:06 pm

Message: VizuaaLOG is not yet permitted to post plain text URLS (300 rep required). 1 URLS removed. Why?
Kyatric wrote:


Thank you, that post helped me fix the problem. i think it is a bug with r169 in the downscaling property. When changing it from 'high quality' to 'medium quality' it fixed the problem. Thank you :)
B
3
Posts: 2
Reputation: 179


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 9 guests