Help! Problem with Audio on Export Node-Webkit

Bugs will be moved here once resolved.

Post » Fri Mar 22, 2013 12:03 am

Link to .capx file (required!):
https://www.dropbox.com/s/hnkpr4a7cmbkt9v/cubekiss.capx

Steps to reproduce:
1. Export on Node-Webkit
2. Test in Windows or Mac OSX (i no have tested on linux)
3. :(

Observed result:
a horrible audio quality in the game: (

Expected result:


Browsers affected:
Chrome: yes/no
Firefox: yes/no
Internet Explorer: yes/no

only in node-webkit exported

Operating system & service pack:
windows seven service pack i don't know

Construct 2 version:
r119
    

All games if i exporte in node-webkit have this problem.
I buy the Construct 2 Personal Edition today;
*Sorry my bad English
B
9
S
1
Posts: 75
Reputation: 1,118

Post » Fri Mar 22, 2013 1:36 am

I'd be tempted to say that the bad audio quality comes from the fact that you're using a KISS song, and the bug fix would be to try to use some good music instead.

But more seriously, I have a few cracks indeed on play but I wouldn't call it a "horrible audio quality".

I don't know if there's much Ashley can do though, it sounds more like an issue that should be reported to node-webkit directly.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Fri Mar 22, 2013 3:59 pm

Closing, as @Kyatric says we can't fix the audio quality, that's an issue with either node-webkit or Chromium.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Mar 22, 2013 4:07 pm

Strange, then it should be only on my PC, because here the original song has a perfect quality, and when I export the game gets a lot of noise with audio, if possible download the version that I exported to windows:
(PS: This also happened using a song my own in another game)

Download off Project exported by me:
https://www.dropbox.com/s/re4sg8uq6ksg5qb/win32.rar

See this man. This isn't normal. I need download of a Driver to correct this? what is this? :(
Extreme noise and music simply not enough to be heard, I believe it is
only here, but I would like to know how to fix it so it will not give :(

Result: If I export a game with a song she gets filthy independent music, and I believe it is only on my computer so that it is exported. =(DFox2013-03-22 16:09:50
B
9
S
1
Posts: 75
Reputation: 1,118

Post » Fri Mar 22, 2013 4:20 pm

Sorry! I resolve the problem.
The "horrible sound" is the music playing 10000000000000000000000000x per second, the music haved "every tick" play sound. Sorry :#
B
9
S
1
Posts: 75
Reputation: 1,118


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 8 guests