[help] spriter objects disappear after exporting

Get help using Construct 2

Post » Sat Mar 29, 2014 1:21 pm

So... I'm making an RPG in C2 and for the battle sprites I use Spriter for easy animation stuffs
this is the battle when in preview:
battle-2.png


but then I tried to export the game to desktop with node-webkit, it all worked fine until I tried the battle scene on the game, then I see this:
battle-3.png


So, the enemy and the character doesn't appear, the only thing that appears is the sword which is the only sprite that is not from Spriter. However even though it wasn't shown the spriter object was created, it's because the sword sprite only created when the hand sprite that is in the same container with the spriter object created.

At first I thought the sprites (and spriter object) was somehow immediately destroyed after created which explained why only the sword was shown. But I can still move right and left with the keyboard input (the background also moved so I can tell) so that means the spriter object was still there, only it's somehow not shown.

and also, because the sword is not moving when it should, it's also somehow unpinned to the hand sprite, or maybe the hand sprite stayed in one location and not visible.

I don't know why this thing happened only when exporting and totally fine when I'm previewing on browser, so I'm appreciating any help from anyone. Does other's project that use Spriter also have this kind of problem?
You do not have the required permissions to view the files attached to this post.
B
45
S
13
G
2
Posts: 173
Reputation: 5,331

Post » Sat Mar 29, 2014 5:27 pm

actually, it's fixed. Turns out I have to uncheck "minify script" when exporting for Spriter plugin to work properly. This topic is closed
B
45
S
13
G
2
Posts: 173
Reputation: 5,331


Return to How do I....?

Who is online

Users browsing this forum: David181, manujorgo, NECRONOMICRON, rbailey83 and 25 guests