Help very strange bug!

Discussion and feedback on Construct 2

Post » Thu Mar 30, 2017 9:46 am

I got a very strange bug and I'm not sure what might cause it or how to properly report it.

I can't preview my project in NWjs or chrome anymore, it just happened all of a sudden with no apparent reason, firefox and edge work fine, NWjs just crashes without a message and chrome gives me "Aw snap, chrome ran out of memory".
Now the strange part is that I tried loading a backup from earlier today, from yesterday and even last month and I'm getting the same results, I tried updating chrome to the latest version, I tried updating Construct from r241 to r243 and fully uninstalling in between and of course restarting my computer.
I know for sure this is not a memory problem, because I tried loading another project which is much much larger and it previews fine, this is a 40mb download and 30mb memory use project.

@Ashley do you have any thoughts?
Image
B
78
S
28
G
12
Posts: 515
Reputation: 12,459

Post » Thu Mar 30, 2017 10:04 am

#UPDATE

After moving my music folder (which is 42 mb for both m4a and ogg files) from the Sounds folder to the Music folder the preview works, but it's still weird, it was always in the Sounds folder so it will preload and play on time when playing online and I didn't change any of these files for quite some time.
I'm guessing it's more due to the fact that more memory is free, but why is there a memory problem to begin with?
I have 16gb of ram and barely 10% in use, it's not a big project and bigger projects with 10 times more memory usage are working fine.
Not to mention loading older versions going back a month, which used to work fine, are also affected, I'm working on this project daily.
Image
B
78
S
28
G
12
Posts: 515
Reputation: 12,459


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests