Host games

Discussion and feedback on Construct 2

Post » Fri Oct 21, 2011 3:49 am

[QUOTE]
So first of all your server is serving offline.appcache with the MIME type text/plain - it should be text/cache-manifest for the offline feature to work properly. However, it shouldn't affect the audio.[/quote]

@Ashley, okay, I checked the MIME types and I cannot see text/cache anywhere. Here's a pic of it.

So I think I should add text/cache?

[quote]By poking around in c2runtime.js, it looks like one of your audio files is:
http://www.dsc.squareserve.org/Player/media/Goblins%20Marching%20in.ogg
This is a 404 so won't play (if I got the URL right). Have you set up the MIME types properly as I described in my last post?[/QUOTE]

This is odd indeed. The link you gave to the audio seems to be correct, but it does give a 404 error. However, I noticed that in my server, that link doesn ot have capitals, only lower case, and it does work [link]. About the ogg MIME type, I think it is correct?
B
47
S
10
G
6
Posts: 455
Reputation: 8,326

Post » Fri Oct 21, 2011 12:53 pm

Ah, the OGG issue might be a C2 bug. I'll see if I can fix that for the next build. On the other hand, you should add the text/cache-manifest (note: not text/cache) MIME type for .appcache files. If you don't have the option to add a MIME type, contact your host and ask them to add it.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574

Post » Fri Oct 21, 2011 8:34 pm

@Ashley, oh I see. I did add that MIME type just now, I am gonna try to see if it works at Dropbox. I just find it odd I haven't heard anybody with this problem, so just to be sure it is not my server, I will do that.

What about the other issue where the application behaves erratically? Also, today I found out that this same thing also happens while in the editor! Sometimes, the project will behave the same way as it does in my server, ogg won't play and it stops reading my events. All I do though, is close C2 and re-open it, and it goes away. You might be right about it being a bug.VampyricalCurse2011-10-21 22:16:08
B
47
S
10
G
6
Posts: 455
Reputation: 8,326

Post » Fri Oct 21, 2011 9:48 pm

Browsers have really crap audio support at the moment - they tend to cut out or crash. I think it might just be the browser. Try keeping your browser up to date and hopefully it will be fixed soon.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574

Post » Fri Oct 21, 2011 10:16 pm

@Ashley, well I'll be. The thing works on Dropbox..... I guess it's my server? I don't understand why. I am gonna have to to contact my server provider. *sigh*
B
47
S
10
G
6
Posts: 455
Reputation: 8,326

Post » Fri Oct 21, 2011 11:14 pm

I'd wait until the next build. I fixed some issues with C2's export of audio files. If you still have trouble in the next build, and you're sure it's not browser bugs, maybe think about contacting your host.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574

Post » Fri Oct 21, 2011 11:51 pm

[QUOTE=Ashley] I'd wait until the next build. I fixed some issues with C2's export of audio files. If you still have trouble in the next build, and you're sure it's not browser bugs, maybe think about contacting your host.[/QUOTE]

Okay I got it. Any idea why it works on DB and not on my server?
B
47
S
10
G
6
Posts: 455
Reputation: 8,326

Post » Sat Oct 22, 2011 12:24 am

Maybe they have different case sensitivity rules. Not sure.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574

Post » Sat Oct 22, 2011 12:46 am

Makes sense. I kindly thank you for yer time and help.
B
47
S
10
G
6
Posts: 455
Reputation: 8,326

Post » Fri Mar 08, 2013 9:58 am

well its an old thread, but I want to ask anyway, I have uploaded my game in my web server, the thing is, after I updated the game and reupload the whole thing, the new updated game is not there, I mean the link was there and working but it's not the newest update. If I tried it in localhost everything is updated. anyone know why? btw I have added the MIME for ogg mp4 and appcache, still no light...
B
4
Posts: 2
Reputation: 304

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 11 guests