How can I disable the "ALT" pause key?

For questions about using Classic.

Post » Thu Sep 22, 2011 12:47 pm

Hello everyone!

I've a problem.
When the game is running, the game pauses when I press the "ALT" key.
Especially, in a platform game, the game glitches.

How can I disable the "ALT" pause key?
Thanks!

Bye!

Example file:
http://www.box.net/shared/omez9tpjnymb5r30k5v6
B
2
G
3
Posts: 9
Reputation: 868

Post » Thu Sep 22, 2011 1:11 pm

The "pause" happens, because "alt" is a system hotkey that sets the focus to the window's system menu (restore, minimize, maximize, exit, etc.) This menu exists if the window has a caption bar (it is the one you get if you left click on the icon in the title bar, or rightclick the title bar). So the quickest way to prevent this behavior without python or some plugin is to disable "caption" in Application Properties/Window Properties, or to go fullscreen.

To be honest, this is the first time that I see this behavior. It is an issue that should be avoided by Construct if possible.
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242

Post » Thu Sep 22, 2011 1:12 pm

Haven't come across this before, but you could click on 'Manage Controls' when on Project, and add a new one for ALT.

*** Damn. Ninja'd by Tulamide.zenox982011-09-22 13:13:39
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,841
Reputation: 48,283

Post » Thu Sep 22, 2011 1:41 pm

Thanks both for the answers! :)

For Zenox98: The solution is valid only if I press "ALT" key, because I've discovered another pause key "F10".

Tulamide: Thanks a lot!Italian2011-09-22 13:47:59
B
2
G
3
Posts: 9
Reputation: 868


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 3 guests