How do I... add a new achievement?

Get help using Construct 2

Post » Mon Nov 05, 2012 3:10 am

For some reason anytime I add a CLAY I/O achievement it just hangs and never loads the layout (even if it's a simple layout w one sprite).

Is there something I need to add before (or after) the Award Achivement to make sure it will load the layout?
Posts: 15
Reputation: 330

Post » Tue Nov 06, 2012 12:24 am

Hmm, it's not right at the start of your game is it? Clay takes a second or two to load, so you have to put the early commands in the event: " Ready" or it will cause a Java error leaving the game hung on a black screen before the progress bar even appears.

Most of it's commands require a small wait, and have "on ready" events for those too. but Setting achievements usually is a set and forget. It will pop up a little window on its own after contacting the server to see if that one has already been achieved.   

It could be another Java error when you award the achievement, are you sure you have the API key set in the Clay Properties? (do other Clay features work?) Java errors usually show in preview mode, not not on exported projects.

Edit: Oh, and " Ready" only fires once, so if you want to check again later, have it set a globle variable. Then you could add a check of the global variable to the setting achievement event, so it won't fire if it's not ready.Paradox2012-11-06 00:41:47
Posts: 889
Reputation: 35,601

Return to How do I....?

Who is online

Users browsing this forum: Aphrodite, zenox98 and 20 guests