How do I add my attack animation??

Get help using Construct 2

Post » Sat Jan 31, 2015 7:38 am

Problem:
So I have the "idle" animation and the "running" animation set. However I want to be able to press "T" and trigger the attacking animation for my character yet when I do that, it starts the animation but quickly stops and goes back to my "idle". I understand that it's being overridden but I can't seem to find a solution to my problem. z

Questions:
Does anyone have a solution?

Concerns:
In the game, you can disregard the crane as it's used for just simple physics for later developments.

Thanks:
Thank you for your time and consideration for this post.
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 3
Reputation: 181

Post » Sat Jan 31, 2015 8:36 am

@virtusal

Try the attached file. I added in a check for "not T keydown" when setting the Running and Idle animations.
You do not have the required permissions to view the files attached to this post.
B
10
S
2
G
1
Posts: 42
Reputation: 798

Post » Sat Jan 31, 2015 3:05 pm

nickl wrote:@virtusal

Try the attached file. I added in a check for "not T keydown" when setting the Running and Idle animations.


You're awesome! However, you see how my character jumps up during the animation transition and performance? Is that due to the collision boxes or the origin? Cause I know that some of my animation frames are smaller in height as the animation progresses and I keep thinking that it may change the smoothness of how it plays in he game, causing that "bump" but I'm not sure.

Edit:
Also, if you play around with the animation while moving and such, the "bump" goes away if you "attack" while moving but doesn't when you stand still.
B
3
Posts: 3
Reputation: 181

Post » Sun Feb 01, 2015 3:32 am

@virtusal
The bump you see has to do with the collision box.
I played around with your collision box and just made sure they all lined up with the bottom of the feet and the bump is gone.
I also reworked the animation event a bit so now once you hit T it will play until the end before it changes to another animation.
You do not have the required permissions to view the files attached to this post.
B
33
S
8
G
2
Posts: 100
Reputation: 2,635

Post » Sun Feb 01, 2015 2:42 pm

@thatserafimkid
awesome! See I thought that was the problem, really I did! However, after changing all of the collisions at the bottom of the feet to be perfectly in line with each other on every frame... I moved on thinking it was something else. Thank you once again!
B
3
Posts: 3
Reputation: 181

Post » Sun Feb 01, 2015 3:27 pm

@virtusal
You're very welcome. At least you were on the right path.
B
33
S
8
G
2
Posts: 100
Reputation: 2,635


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 58 guests