How do I build.phonegap.com

Get help using Construct 2

Post » Wed Sep 23, 2015 11:10 pm

Up until today I have been able to export via cordova and upload a zipped copy of my export directory into build.phonegap.com. From there I would upload and rebuild the app in order to get a new .apk file. Today it appears like they update their build.phonegap.com system to a new version now I can't rebuild anything that worked yesterday. I even removed all plugins related to phonegap and still have the issue. Is there a switch somewhere that I can reset the compiler on build.phonegap.com to the version it used yesterday or will I need to wait for @Ashley and the team to push an update for Phonegap export?

Here's the error. Maybe it'll make sense to someone else:
Error - Some official plugins have to be updated if using PhoneGap >= 4.0.0. Please upgrade the version of any plugins that may include the following file: InAppBrowser.java - You can fix this here
www.h1k3.tech

We are here for you!
B
87
S
22
G
16
Posts: 715
Reputation: 16,785

Post » Thu Sep 24, 2015 1:30 am

Hi, lanceal.
I'm having the same issue. Everything was working till today. Now I can't build my app for Android anymore.
I'm using the InnAppBrowser plugin (org.apache.cordova.inappbrowser)
Any idea of how to solve this?
B
2
Posts: 2
Reputation: 154

Post » Thu Sep 24, 2015 2:30 am

I dont use that plugin, i dont think. Im new to phonegap. I dont have a clue how to fix it.
www.h1k3.tech

We are here for you!
B
87
S
22
G
16
Posts: 715
Reputation: 16,785

Post » Thu Sep 24, 2015 11:19 am

@lanceal, @jakejake, I'm also experiencing problems.

Today's the first time I've uploaded to PhoneGap for a few days, and I keep getting the same error message as you. However, I don't use the InAppBrowser.java plugin (at least not as far as I'm aware).

PhoneGap is perfectly suited to the app I'm currently working on. So I really hope the issue can be resolved soon.
B
33
S
6
G
7
Posts: 494
Reputation: 8,252

Post » Thu Sep 24, 2015 12:08 pm

File a bug report for this and I'll take a look.
Scirra Founder
B
387
S
230
G
88
Posts: 24,254
Reputation: 192,470

Post » Thu Sep 24, 2015 2:34 pm

Same problem, i'll check if there is any bug report allready fullfilled. in fact i have any clue on how fullfill the bug report, also my english is pretty bad.

Here the message i get for the android build in phonegap

"Error - Some official plugins have to be updated if using PhoneGap >= 4.0.0. Please upgrade the version of any plugins that may include the following file: InAppBrowser.java - You can fix this here"

Somebody better in english than me to write this bug report ?
B
14
S
1
Posts: 33
Reputation: 1,022

Post » Thu Sep 24, 2015 7:51 pm

We solved the issue.
I guess that <preference name="phonegap-version" /> in the config.xml file forces the app to be built with the latest phonegap version available, which is cli-5.2.0.
I noticed that our other app was still using 3.7.0, but we hadn't rebuilt it.
Something might have happened yesterday that started forcing the "new" version to all apps when we rebuilt them.

So, what we did was to specifically force the phonegap version 3.7.0:
<preference name="phonegap-version" value="3.7.0" />

Now it builds fine.
I hope this helps you all.

Jake
B
2
Posts: 2
Reputation: 154


Return to How do I....?

Who is online

Users browsing this forum: 99Instances2Go, DuqueKarl, Vinterstille and 2 guests