How do I custom move after creation

Get help using Construct 2

Post » Thu Jun 25, 2015 7:20 am

so i have an object with destroy outside of layout and custom movement.

on start of layout i do this:
Code: Select all
                 - create object
                 - set custom movement angle 90
                 - set custom movement speed 20 overall         


and then that object goes to the right (angle 0) with speed 20 - wtf?
i've tried moving setting to "on created", doesn't work aswell. tried on every X sec (set like 3-4 sec) and then it works, but it moves 3-4 sec to right first then changes. wtf? how do i do that on object creation? what gives?
Sea Monsters template - Isometric
Also includes 40 pages PDF of optimizations and "how-to" for your games, and how the "sea monsters" template was built. Follow link for details :)

sea-monsters-templates-and-assets_t162705
B
43
S
14
G
12
Posts: 626
Reputation: 9,450

Post » Thu Jun 25, 2015 7:30 am

You should set the speed before setting the angle..
Without speed there is no movement, so the angle of movement can't be set..
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Thu Jun 25, 2015 8:01 am

omfg that worked :facepalm:

and there i thought it was just a property to know the angle of movement non dependant of speed :/

thnx
Sea Monsters template - Isometric
Also includes 40 pages PDF of optimizations and "how-to" for your games, and how the "sea monsters" template was built. Follow link for details :)

sea-monsters-templates-and-assets_t162705
B
43
S
14
G
12
Posts: 626
Reputation: 9,450


Return to How do I....?

Who is online

Users browsing this forum: Yahoo [Bot] and 24 guests