How do I disable Mouse at Screen borders?

Get help using Construct 2

Post » Fri Oct 17, 2014 12:52 am

Message: Edelplastic can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
Hello.

I have a problem with a Breakout Game compiled for Node-Webkit. If i test my Game in Construct 2 (Node-Webkit + Resolution 1920x1080 + Innerscale Fullscreen) all works great, all works perfect. But if i compile the Game with the same options, i get a problem with the Screen borders. If i move my Mouse to the Edges of the Screen, the Mouse are shown and i can not control the Player-Paddle - if i move the mouse away from the Edges, i can move the Paddle.

I have test it with all fullscreen options, but the problem with the screen borders are resists.

(I have disable all options for the Node Webkit when i compile the Game // Single instance - window frame - resizable window - kiosk mode)

Image

Here you can Download the Game for testing. Please use ALT+F4 to exit the Game!

https://www.dropbox.com/s/2gcwkui72v7dh68/BPM.zip?dl=0
B
8
S
2
Posts: 53
Reputation: 687

Post » Fri Oct 17, 2014 1:59 am

B
99
S
35
G
29
Posts: 3,139
Reputation: 28,421

Post » Fri Oct 17, 2014 2:20 am

What are your events for hiding the mouse? Do you have a condition that says something like "as long as the mouse *something* then move paddle"?

i had never run into something like this before in node-webkit.
B
43
S
12
G
6
Posts: 446
Reputation: 6,807

Post » Fri Oct 17, 2014 2:38 am

@Joannesalfa: Thank you, the Plugin works perfect! Now the Problem is solved :D

@Sargas: I have use the standart Mouse Event "Set Cursor to None" to hide the Cursor (see the picture)

Image

And for move the Paddle i have use the Event : System Timescale ≠ 0 -> Paddle Set X to Mouse.X
B
8
S
2
Posts: 53
Reputation: 687


Return to How do I....?

Who is online

Users browsing this forum: Google [Bot] and 5 guests