How do I disable Sprite Font collisions ?

Get help using Construct 2

Post » Thu Oct 16, 2014 9:46 am

Hey all,

I just noticed in the debug that sprite fonts and text boxes have collisions set to enabled. How do i make them disabled on startup. Unlike normal sprites there are no options for sprite fonts to turn off their collisions.

And also 'touch' also seems to use collisions to detect if it's touching an object or not. Is there a work around for this? I have a lot on sprites on screen and touching makes the collision check count jump to very high values.
B
16
S
4
Posts: 138
Reputation: 1,454

Post » Thu Oct 16, 2014 9:12 pm

Good question....unfortunately I don't really know how to help...

you could try putting a Behavior like "Solid" onto the objects and then manually disabling the Collisions On start of layout...

I would try that to see if its a possible workaround

but you are right,

those objects dont seem to have a collisions checkbox, I never noticed before
When in doubt..or you are lost in a Zombie apocalypse or someone is giving you a hard time..Remember one thing..... Read the Construct 2 Manual..it will save your life.:)
B
35
S
13
G
8
Posts: 318
Reputation: 7,685

Post » Fri Oct 17, 2014 2:34 pm

Collisions, if not verified by a behaviors (platform, solid, jump thru, etc...) or an event (on collision, is overllaping, on touched object maybe..), are not processed AT all, so you should not worry about that, as this setting make sense only when using the collisions actively.
Game design is all about decomposing the core of your game so it becomes simple instructions.
B
53
S
22
G
18
Posts: 2,122
Reputation: 17,123


Return to How do I....?

Who is online

Users browsing this forum: David181, evillair and 62 guests