How do I do a custom loading page?

Get help using Construct 2

Post » Sun Apr 10, 2016 10:05 pm

I read the tutorials and gave it a try, however, for half the loading time I see whatever the loader style is set to (currently it's for nothing, but if I have it for the bar or percent, that will show), and then pops up my custom loading page with it set so it displays the percent, which only goes to about 30% and then it goes to my game.
This is really evident when I'm loading in on my iPad (since it's slower than my PC).

Here's a link to the game posted on my site:
http://www.yourkidcanread.com/HTML5%20g ... index.html

So, my question is - is this normal? Shouldn't it just go right to the custom loading page?
B
10
S
3
Posts: 51
Reputation: 764

Post » Mon Apr 11, 2016 3:47 am

The initial loading you're seeing is because it must load in the assets for your loading screen before it can show it. I prefer setting it to black for this very reason. Keep your loader layout light-weight, and that initial load will be shorter. As far as only going to about 30%, I have no idea without seeing your capx, unfortunately. Are you checking the loading progress vs 0 through 1.0?
B
103
S
38
G
19
Posts: 962
Reputation: 17,996

Post » Mon Apr 11, 2016 2:55 pm

Thanks for your reply. I did set the background to black, and the loading layout page only has 2 text objects on it (to display "Loading..."
and to give the % (with>> round(loadingprogress*100)&"%"). That's very light weight, but it's still happening.

To make it more clear, I made the loader style to display the %, and now I can see that it loads over 75% before switching to my loading page.
I can PM you OneDrive link if you'd like to take a look.
B
10
S
3
Posts: 51
Reputation: 764


Return to How do I....?

Who is online

Users browsing this forum: brunopalermo, MikaelS, nahima and 21 guests