How do I eliminate jerkiness/tearing when fullscreen

Get help using Construct 2

Post » Thu Apr 28, 2016 2:49 am

Here's the capx: https://dl.dropboxusercontent.com/u/280 ... test5.capx

Here's the exported game:
https://dl.dropboxusercontent.com/u/280 ... index.html

OK I know it's the usual problem:
* pixelart game,
* ultra small resolution 128x96
* pixel rounding on (because I don't like sub-pixels showing whenever enemies are trying to find their footing on platforms).

I've set fullscreen to letterbox integer, so you can see for yourselves. Just run the game and resize the window.

When the game window is 640x480 or less, beautiful, smooth movement. Yes, it's 1 pixel at a time, but that's what's intended.


When you resize the game window to be more than 640x480, or even worse Fullscreen, there's a ton of jerking which doesn't feel like 1 pixel at a time. It feels like the screen is tearing as well. In any case, it's suddenly not at all smooth, and it happens just a few pixels above 640x480.

Can anyone help, this issue makes me want to seriously quit trying pixelart games on C2.

Is it a timedelta thing? Is it a mistake on my part? I'm just using the standard platform movement.
Is it a monitor thing? I'm noticing my second (older, crappier) monitor is almost unaffected, on chrome! Both my monitors are affected on nw.js.

However both my monitors can play, for example, a mame-emulated version of Rainbow Islands with perfect full-scale frame rate and no jerking.


@Ashley I wish there was a way for Construct 2 to work in a mode that emulates an older processor chip, with a specific frame rate, and adjusts everything so that it looks good on modern monitors.

thanks to anyone who takes the time, it means a lot to me.
B
28
S
12
G
4
Posts: 193
Reputation: 4,581

Post » Thu Apr 28, 2016 3:36 am

um putting it out there: I would never have thought of it, but someone on twitter told me to turn windows aero back on. Apparently windows disables vsync when aero is disabled? I'm so weirded out. Thanks for listening
B
28
S
12
G
4
Posts: 193
Reputation: 4,581

Post » Thu Apr 28, 2016 6:30 am

It's working just fine here, no tearing at all but the character does "shake" a little bit while the camera is following her. I'm running the latest preview version of Windows 10 (14332).
B
123
S
43
G
41
Posts: 847
Reputation: 28,206

Post » Thu Apr 28, 2016 10:24 am

You're right. That might have to do with player.platform.maxSpeed
Maybe she needs to move exactly a specific number of pixels for it to work. Hm
B
28
S
12
G
4
Posts: 193
Reputation: 4,581

Post » Thu Apr 28, 2016 10:56 am

christina wrote:You're right. That might have to do with player.platform.maxSpeed
Maybe she needs to move exactly a specific number of pixels for it to work. Hm


I messed around with your .capx because I thought it had something to do with the way the camera worked, but what you said was just it. I think she's running so slow that you can actually see she shifting through every pixel. If you use 60 as her maxspeed, everything is really smooth.
B
123
S
43
G
41
Posts: 847
Reputation: 28,206

Post » Thu Apr 28, 2016 12:34 pm

60 is too fast. Are we sure it can't work with smaller max speeds? If so, I should have thought twice about the tiny size
B
28
S
12
G
4
Posts: 193
Reputation: 4,581

Post » Thu Apr 28, 2016 2:39 pm

Maybe if you put a lerp on all the camera movements.
Image ImageImage
B
169
S
50
G
170
Posts: 8,292
Reputation: 108,728

Post » Thu Apr 28, 2016 3:20 pm

thanks @newt. Tried it, it's even jerkier then! Try it?
B
28
S
12
G
4
Posts: 193
Reputation: 4,581

Post » Thu Apr 28, 2016 3:29 pm

Honestly it's not jerky here.

Edit.
How does this:
https://newt.itch.io/oort
Work for you?
Image ImageImage
B
169
S
50
G
170
Posts: 8,292
Reputation: 108,728

Post » Thu Apr 28, 2016 5:02 pm

in full screen? it's very jerky, yes. Performance is smooth, but lerp scrolling is jaggy.
B
28
S
12
G
4
Posts: 193
Reputation: 4,581

Next

Return to How do I....?

Who is online

Users browsing this forum: ChesVCF, LaDestitute, OBLIVION, yiuyiu6666 and 25 guests