How do I fix a cant read property '?' of undefined error?

Get help using Construct 2

Post » Wed Mar 12, 2014 8:19 am

Hi all,

I am doing a project in construct, which was going fine before the weekend, last test export working and all.

However, as I did an test today (without changing anything) I got an javascript error in the console:

Uncaught TypeError: Cannot read property 'poly_pts' of undefined.

Using FireFox' console, I get the folowing:
TypeError: this.type.animations[0].frames[0] is undefined


I have absolutely no idea where this came from, and I am lost as I don't know what could be the issue..
B
7
S
2
G
2
Posts: 46
Reputation: 769

Post » Wed Mar 12, 2014 8:51 am

Have you installed an addon?
I will not let you reach the sisters
Nature Forums
B
11
S
5
G
2
Posts: 496
Reputation: 2,306

Post » Wed Mar 12, 2014 1:11 pm

Doc Ai wrote:Have you installed an addon?

Only the CallJS plugin. I got around it by reverting to an older project from last week, so let's hope that this doesn't happen again.
B
7
S
2
G
2
Posts: 46
Reputation: 769

Post » Wed Mar 12, 2014 1:55 pm

Please report issues like this to the bugs forum following all the guidelines (and note bug reports must not contain third party plugins).
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762

Post » Wed Mar 12, 2014 3:28 pm

^Oops, sorry Ashley! I will make sure that this won't happen again!
B
7
S
2
G
2
Posts: 46
Reputation: 769


Return to How do I....?

Who is online

Users browsing this forum: evillair and 11 guests