How do I fix a long load time/odd loading behaviour

Get help using Construct 2

Post » Sat Oct 24, 2015 10:09 am

If you go here: http://levelupjordan.itch.io/rick-and-morty-thing (I know the zoom is odd, there's a full screen button in the bottom right) 's and click on S01E09 you'll notice it sort of crashes the browser and takes a while to load.

I can't figure out why it's doing this, my only guess is the size of the layout but I thought layout size wasn't an issue.

Here's the capx: http://www.filedropper.com/roar2 It's messy, but the relevant bits are pretty simple I think.

Thank you!
B
23
S
4
G
1
Posts: 71
Reputation: 8,346

Post » Sat Oct 24, 2015 10:22 am

Doesn't take long to load here.. Just a few seconds..

Actually S01E09 loads almost instantaniously..

Not sure if it's the issue, but the estimated memory-use in the editor is 231.2 MB..
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Sat Oct 24, 2015 10:31 am

Hmm, weird. Maybe it's my laptop, everything else works fine though.

I noticed the large memory use, I assumed that was correlated with layout size and am not sure how to fix it.

Thanks for your input!
B
23
S
4
G
1
Posts: 71
Reputation: 8,346

Post » Sat Oct 24, 2015 10:47 am

I think it has to do with using too large images..

Your tiled backgrounds are more than 5000px wide and 1200px high and you use 4 of them on one layout..
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Sat Oct 24, 2015 10:51 am

That's a valid point. I'll think of a way to address it. Cheers!
B
23
S
4
G
1
Posts: 71
Reputation: 8,346

Post » Sat Oct 24, 2015 11:25 am

Got it down to 75ish, thanks again!
B
23
S
4
G
1
Posts: 71
Reputation: 8,346


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 23 guests