How do I fix layer-skip problem?

Get help using Construct 2

Post » Fri Aug 19, 2016 2:51 pm

I've been working on creating my activity using layers instead of layouts. I've got a background layer plus several layers with varying text and pictures on them. When the project loads the first layer is visible (which I want), and there's a clickable sprite on the background layer (always visible) that should take the user to the specified layer. However, when I click on it it takes me to the last layer. There's also a back sprite on the background layer, and if I click on that one while on the last layer it takes me to the previous layer and I can do so all the way to the first layer. So in a nutshell the back sprite is working fine, but the next sprite always takes me to the last layer regardless of what layer I'm currently on. I saw a topic where a user was having the same problem but the answer seemed to be highly specific for his/her problem. Anyone else encounter this or know how to remedy it?
B
6
S
1
Posts: 16
Reputation: 384

Post » Fri Aug 19, 2016 5:37 pm

hmm sound like you have the object near each other where when you click its just balling the conditional event. I remember that if you place the order of event to be back ward it should delay it conditional check for when you mouse click but that worked in some cases.

Can you make some layer visible and invisible and add in a condition if layer is visible ?
B
52
S
24
G
6
Posts: 391
Reputation: 7,855

Post » Fri Aug 19, 2016 6:16 pm

Doing the events in a backward order worked beautifully! Thank you so much for your help!!!
B
6
S
1
Posts: 16
Reputation: 384


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 5 guests