How do I fix my wall slide move?

Just started using Construct 2? Post your questions here

Post » Sat Aug 15, 2015 7:04 am

Hello all. I've been watching with a bunch of tutorials lately trying to learn all I can with Construct 2. I'd like to eventually make a "Metroidvania" Action Adventure platformer one day. Today, I've been messing around with the event sheet trying to solidify the game mechanics I imagine my game having. Right now I'm working on a wall slide function.

I seem to have it mostly working right but there's a problem. If I keep holding left (or right once I add that bit of the code in) after there's no more wall to slide on, my character keeps floating down in the wall slide animation until I land on the floor. Basically, my character goes into a wall slide if the player is holding correct direction and the player jumps onto or falls onto the wall. I'm adding my capx and a screenshot of my wall slide code. I'm pretty happy I mostly figured it out but it's not right yet.

And another quick question. Unrelated. Should I be using my tilemap the way I'm using them. I've got one tile map and I'm using it two different ways. I've got one cut up into 8x8 and the other cut up into 32x32. I imagine I'm wasting space and should just use the 8x8, right?

I'd also appreciate it if someone would let me know if there's a easier way or shorter way to accomplish what I'm trying to do. Anyway, thanks a lot!

edit: Hmmm, I'm not really sure how to attach my capx the way I see other people do it through scirra. If someone can tell me how to do that too, I'd appreciate it. I just uploaded my file to mediafire in the meantime. Copy and paste the link directly below. Thanks!

mediafire.com/download/inxbd3rf1jg4s1z/Tilemap_Plat_Test.capx

Image
B
28
S
14
G
21
Posts: 179
Reputation: 13,548

Post » Mon Aug 17, 2015 10:15 pm

Hey there. I downloaded your capx and I'm not experiencing your problem. The animations seem to be working correctly. Did you already fix the issue?
B
54
S
32
G
23
Posts: 333
Reputation: 16,591

Post » Tue Aug 18, 2015 9:02 am

Hey again!

So I stumbled on your problem and subsequently fixed the issue. Here's what you need to change your code to (I boxed in my changes):

Image

I hope that helps!
B
54
S
32
G
23
Posts: 333
Reputation: 16,591

Post » Wed Aug 19, 2015 10:10 am

hey ultrafop, thanks for the help! I actually solved my problem another way. I just added the event "Playerbox - platform is falling > Set Platform max fall speed to 1000" at the top.
B
28
S
14
G
21
Posts: 179
Reputation: 13,548

Post » Thu Aug 20, 2015 5:30 pm

Oh, nice!
B
54
S
32
G
23
Posts: 333
Reputation: 16,591


Return to Beginner's Questions

Who is online

Users browsing this forum: Jetzoo1 and 2 guests