How do I fix this little & annoying problem?

Get help using Construct 2

Post » Tue May 30, 2017 10:19 pm

Hi
I'm trying to figure this out, but it don't seen like my code problem.
WIth a gravity centered in screen, with the player moving aroud it there is a big delay in the jump, and even the jump not work at all.

Can anyone try and maybe show me why it happen?

Thanks in advance
°°°

EDIT: forgot the link xD : https://www.dropbox.com/s/wnfphe2apkrsl ... .capx?dl=0
"Do what you must" -The Elder (Titan Souls)
B
27
S
13
G
4
Posts: 73
Reputation: 4,311

Post » Wed May 31, 2017 8:08 am

Platform can only jump when on the floor.
But.
Due the very rough collision polygons in that circle, the platform is constantly in the state of 'falling'.
Hence, not on the floor.

You have to make the collision polygons of that circle a LOT better so it comes a LOT closer to a circle.
Instead of being just a rough polygon.

Now, i am to lazy to do that. (that is like making at least 240 points, and moving them in the right position)
And you did not even try.
So, lets force the system to make a perfect polygon that is close to a perfect circle as possible.

https://www.dropbox.com/s/8bgzojbw74ah9 ... .capx?dl=0

You need a plugin in for this, it will tell you which one on loading.
B
33
S
18
G
28
Posts: 2,493
Reputation: 20,950

Post » Wed May 31, 2017 5:45 pm

Oh nice, it sounds perfect, I should have notice the floor problem! Thank you @99Instances2Go, for the help + improvement, this Polygon plugin is really useful, glad you present it to me.
Be blessed /\
"Do what you must" -The Elder (Titan Souls)
B
27
S
13
G
4
Posts: 73
Reputation: 4,311


Return to How do I....?

Who is online

Users browsing this forum: AllanR, brunopalermo, ST314, TheRealDannyyy, tunepunk and 22 guests