How do I get a tiled background working

Just started using Construct 2? Post your questions here

Post » Thu Feb 05, 2015 1:07 am

Message: Coolbreeze is not yet permitted to post plain text URLS (300 rep required). 2 URLS removed. Why?
Hi,

I'm working through the New Boston Platformer tutorial and using the following tiled background from Open Game Art, since I'm trying out the free version of Construct 2.

New Boston Platformer tutorialThe problem is according to the tutorial I need to set my position for the background to 0,0 and the size to the layout size, which is 4000,2048. I've done that, but the tiled background isn't filling the layout like in the video.

Here is how mine is displaying. How can I get the background to display properly?
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 5
Reputation: 185

Post » Thu Feb 05, 2015 2:05 am

I think a problem with constructor 2 version. What version?
B
15
S
4
G
1
Posts: 64
Reputation: 10,842

Post » Thu Feb 05, 2015 11:08 am

Yes I am using Construct 2 r195. Is there anything I can do to fix it?
B
3
Posts: 5
Reputation: 185

Post » Thu Feb 05, 2015 11:53 am

Post your .capx - makes it much easier for helpers to see, and hopefully fix, whatever problem you have.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
126
S
29
G
73
Posts: 5,091
Reputation: 52,002

Post » Thu Feb 05, 2015 11:55 am

Coolbreeze have look at this demo and work it out
You do not have the required permissions to view the files attached to this post.
B
231
S
33
G
14
Posts: 1,908
Reputation: 38,742

Post » Thu Feb 05, 2015 10:08 pm

I've attached my .capx file. Please have a look.

@Lordshiva1948, I want to find out if it's just something I'm doing wrong as I prefer to use a stable version, but will install the beta and try your file in a VM.
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 5
Reputation: 185

Post » Fri Feb 06, 2015 9:35 am

here try this
You do not have the required permissions to view the files attached to this post.
B
231
S
33
G
14
Posts: 1,908
Reputation: 38,742

Post » Fri Feb 06, 2015 11:24 am

Everytime I try to open the files, I get a message about them being saved with version r196.2 and me having r195 and needing to upgrade to a newer version before I can open them.

Would you happen to have r195 still around? I really would like to stick to the stable version if possible and get this working.
B
3
Posts: 5
Reputation: 185

Post » Fri Feb 06, 2015 8:53 pm

Coolbreeze sorry mate I don't have it but, just download 196.2 you be fine.
B
231
S
33
G
14
Posts: 1,908
Reputation: 38,742

Post » Sat Feb 07, 2015 3:32 am

Thanks Lordshiva, I'm seeing now after I upgraded and tried your demo background, that it's not a problem with the background I was using per se, but that you can't just import any background and expect it to display properly when tiled. You may have to adjust your layout and/or image size as well.
B
3
Posts: 5
Reputation: 185


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 0 guests