How do I get Appodeal working on my app?

Get help using Construct 2

Post » Tue Mar 22, 2016 4:34 pm

Hi!

You not needed to write this project name manually. Plugin will be do it automatically. I recommend to delete project that you have created manually and restart plugin again :-)

Hope tis works
B
2
Posts: 4
Reputation: 154

Post » Tue Mar 22, 2016 8:32 pm

Hey, thanks @Natx... but what do I actually write in the three 'git repo' spaces (or am I supposed to be using the 'Cordova plugin registry', like I did)?

Image
B
36
S
9
G
1
Posts: 629
Reputation: 3,956

Post » Sun Mar 27, 2016 11:30 pm

In theory you have two options:

1. Using officiall Appodeal setup.
- C2 Appodeal's official plugin: http://www.appodeal.com/system/uploads/ ... 1.14.9.zip
- Then In Intel XDK you have to add two plugins:
* https://github.com/appodeal/PhoneGap-Go ... rvices.git
* https://github.com/appodeal/cordova-plugin.git

2. Using @Cranberrygame Appodeal setup.
- C2 plugin is within Cranberries plugin pack
- Intel XDK plugin: https://github.com/cranberrygame/cordov ... podeal.git

The problem is that I have just tried both and I can't get any to work. With the official Appodeal setup I can't build an app. It gives compilation error.
With Cranberrygame's setup I cannot even add the plugin in Intel XDK.

Can someone who managed to set it up put some light on this situation please?
ImageImageImage
B
28
S
16
G
82
Posts: 1,031
Reputation: 45,806

Post » Mon Mar 28, 2016 12:10 pm

BackendFreak wrote:
The problem is that I have just tried both and I can't get any to work. With the official Appodeal setup I can't build an app. It gives compilation error.
With Cranberrygame's setup I cannot even add the plugin in Intel XDK.

Can someone who managed to set it up put some light on this situation please?


I suppose that the problem might be in libraries, if you've tried to edit them or in DEX files, cause if u're using lots of them there can be some limits on permissions. Anyway I'd suggest contacting their support directly and explain the problem, they have live chat on home page so it won't take long
B
4
S
1
Posts: 17
Reputation: 378

Post » Mon Mar 28, 2016 11:17 pm

@BackendFreak 2 days ago I used v 1.14.6 and worked, now v1.14.9 also give me error in IntelXDk
B
82
S
21
G
23
Posts: 520
Reputation: 18,737

Post » Tue Mar 29, 2016 12:09 am

Ah so it's their plugin. Did you use both version with the same Intel XDK version?

BTW: I sent them an email two days ago, but no reply yet.

BTW2: can I get the older plugin version anywere?
ImageImageImage
B
28
S
16
G
82
Posts: 1,031
Reputation: 45,806

Post » Tue Mar 29, 2016 12:30 am

I talked to one of the guys 10 min ago and said that I get build error in IntelXDK with appodeal plugin and they said to show my C2 code...
To get the XDK v1.14.6 put on git repo: https://github.com/Tamplier/Appodeal-PhoneGap-plug
with this one I only get the banner showing now, is strange or I'm to tired, I used to get both interstitial/video ads 2 days ago
B
82
S
21
G
23
Posts: 520
Reputation: 18,737

Post » Tue Mar 29, 2016 2:17 am

@BackendFreak and @Cipriux -- unfortunately, all of those admob plugin authors keep changing their code and versions, it is very hard to keep track of what works and what does not work, especially in combination with other plugins. Many of those plugins pull in other plugins, which just further confuses the issue. The best way to help us help you is to see if you can isolate the specific plugin or plugins that are causing the build errors, by removing and rebuilding. It also helps if you attach the entire detailed build log to your XDK forum posts (please attach as a file, not in the post) so we can see what the specific error is. This is not a guarantee that we can figure out the problem, but it helps about 50% of the time. Keep in mind that there is no official AdMob sponsored plugin, Google/AdMob have never created one. There are about 45 AdMob plugins in the Cordova registry, I recommend you check some of the other authors out if you are having troubles with specific plugins. And, please review the "fork graphs" on the plugin github sites, you may find someone has fixed the problems in a specific plugin. Also, check the issues pages for those plugins on their respective github repos.
Intel Corporation
B
13
S
3
Posts: 79
Reputation: 925

Post » Tue Mar 29, 2016 2:27 am

@xmnboy I inderstand it is all complicated to figure out. I posted an empty project with only Appodeal GooglePlayServices plugin. I think is the Appodeal plugin the issue, but the build code say error code 0 when installing it.
Please have a look
viewtopic.php?f=146&t=170590&p=1025713#p1025713
Code: Select all
Calling plugman.fetch on plugin ".../cachedPlugins.w1sz4b.tmp/cache.40mo1D.pl/cordova-plugin-device"
Copying plugin ".../cachedPlugins.w1sz4b.tmp/cache.40mo1D.pl/cordova-plugin-device" => ".../_A_podeal/plugins/cordova-plugin-device"
Calling plugman.install on plugin ".../_A_podeal/plugins/cordova-plugin-device" for platform "android
Installing "cordova-plugin-device" for android
Running command: .../_A_podeal/platforms/android/cordova/version
Command finished with error code 0: .../_A_podeal/platforms/android/cordova/version
Install start for "cordova-plugin-device" on android.
Install complete for cordova-plugin-device on android.
Searching PlatformJson files for differences between project vs. platform installed plugins
No differences found between project and android platform. Continuing...
Generating config.xml from defaults for platform "android"
Wrote out Android application name to "_A_podeal"
Wrote out Android package name to "com.synapseone.test3"
This app does not have launcher icons defined
updated project successfully
Calling plugman.fetch on plugin ".../cachedPlugins.w1sz4b.tmp/cache.gD_HD2.pl/cordova-plugin-splashscreen"
Copying plugin ".../cachedPlugins.w1sz4b.tmp/cache.gD_HD2.pl/cordova-plugin-splashscreen" => ".../_A_podeal/plugins/cordova-plugin-splashscreen"
Calling plugman.install on plugin ".../_A_podeal/plugins/cordova-plugin-splashscreen" for platform "android
Installing "cordova-plugin-splashscreen" for android
Running command: .../_A_podeal/platforms/android/cordova/version
Command finished with error code 0: .../_A_podeal/platforms/android/cordova/version
Install start for "cordova-plugin-splashscreen" on android.
Install complete for cordova-plugin-splashscreen on android.
Searching PlatformJson files for differences between project vs. platform installed plugins
No differences found between project and android platform. Continuing...
Generating config.xml from defaults for platform "android"
Wrote out Android application name to "_A_podeal"
Wrote out Android package name to "com.synapseone.test3"
This app does not have launcher icons defined
updated project successfully
Calling plugman.fetch on plugin ".../cachedPlugins.w1sz4b.tmp/cache.twpqFE.pl/com.appodeal.googleplayservices"
Copying plugin ".../cachedPlugins.w1sz4b.tmp/cache.twpqFE.pl/com.appodeal.googleplayservices" => ".../_A_podeal/plugins/com.appodeal.googleplayservices"
Calling plugman.install on plugin ".../_A_podeal/plugins/com.appodeal.googleplayservices" for platform "android
Installing "com.appodeal.googleplayservices" for android
Running command: .../_A_podeal/platforms/android/cordova/version
Command finished with error code 0: .../_A_podeal/platforms/android/cordova/version
Install start for "com.appodeal.googleplayservices" on android.
Install complete for com.appodeal.googleplayservices on android.
Searching PlatformJson files for differences between project vs. platform installed plugins
No differences found between project and android platform. Continuing...
Generating config.xml from defaults for platform "android"
Wrote out Android application name to "_A_podeal"
Wrote out Android package name to "com.synapseone.test3"
This app does not have launcher icons defined
updated project successfully
Calling plugman.fetch on plugin ".../cachedPlugins.w1sz4b.tmp/cache.mxQkcw.pl/com.appodeal.plugin"
Copying plugin ".../cachedPlugins.w1sz4b.tmp/cache.mxQkcw.pl/com.appodeal.plugin" => ".../_A_podeal/plugins/com.appodeal.plugin"
Calling plugman.install on plugin ".../_A_podeal/plugins/com.appodeal.plugin" for platform "android
Installing "com.appodeal.plugin" for android
Running command: .../_A_podeal/platforms/android/cordova/version
Command finished with error code 0: .../_A_podeal/platforms/android/cordova/version
Install start for "com.appodeal.plugin" on android.
Install complete for com.appodeal.plugin on android.
Searching PlatformJson files for differences between project vs. platform installed plugins
No differences found between project and android platform. Continuing...
Generating config.xml from defaults for platform "android"
Wrote out Android application name to "_A_podeal"
Wrote out Android package name to "com.synapseone.test3"
This app does not have launcher icons defined
updated project successfully
Calling plugman.fetch on plugin ".../cachedPlugins.w1sz4b.tmp/cache.ZdrA43.pl/cordova-plugin-whitelist"
Copying plugin ".../cachedPlugins.w1sz4b.tmp/cache.ZdrA43.pl/cordova-plugin-whitelist" => ".../_A_podeal/plugins/cordova-plugin-whitelist"
Calling plugman.install on plugin ".../_A_podeal/plugins/cordova-plugin-whitelist" for platform "android
Installing "cordova-plugin-whitelist" for android
Running command: .../_A_podeal/platforms/android/cordova/version
Command finished with error code 0: .../_A_podeal/platforms/android/cordova/version
Install start for "cordova-plugin-whitelist" on android.
Install complete for cordova-plugin-whitelist on android.

               This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in.
         
Searching PlatformJson files for differences between project vs. platform installed plugins
No differences found between project and android platform. Continuing...
Generating config.xml from defaults for platform "android"
Wrote out Android application name to "_A_podeal"
Wrote out Android package name to "com.synapseone.test3"
This app does not have launcher icons defined
updated project successfully
Calling plugman.fetch on plugin ".../cachedPlugins.w1sz4b.tmp/cache.HWuPCT.pl/cordova-plugin-crosswalk-webview"
Copying plugin ".../cachedPlugins.w1sz4b.tmp/cache.HWuPCT.pl/cordova-plugin-crosswalk-webview" => ".../_A_podeal/plugins/cordova-plugin-crosswalk-webview"
Calling plugman.install on plugin ".../_A_podeal/plugins/cordova-plugin-crosswalk-webview" for platform "android
Installing "cordova-plugin-crosswalk-webview" for android
Running command: .../_A_podeal/platforms/android/cordova/version
Command finished with error code 0: .../_A_podeal/platforms/android/cordova/version
Install start for "cordova-plugin-crosswalk-webview" on android.
Install complete for cordova-plugin-crosswalk-webview on android.
Searching PlatformJson files for differences between project vs. platform installed plugins
No differences found between project and android platform. Continuing...
Generating config.xml from defaults for platform "android"
Wrote out Android application name to "_A_podeal"
Wrote out Android package name to "com.synapseone.test3"
This app does not have launcher icons defined
updated project successfully
Searching PlatformJson files for differences between project vs. platform installed plugins
No differences found between project and android platform. Continuing...
Generating config.xml from defaults for platform "android"
Wrote out Android application name to "_A_podeal"
Wrote out Android package name to "com.synapseone.test3"
This app does not have launcher icons defined
updated project successfully
************* Processing the main config.xml file (after_prepare)  *****************
App Directory = [.../_A_podeal]
Will process and update the following config files:
    Config.xml = [.../_A_podeal/config.xml]
Namespaces:
    prefix/uri ''/'http://www.w3.org/ns/widgets'
    prefix/uri 'intelxdk'/'http://xdk.intel.com/ns/v1'
Android Manifest Namespaces:
    prefix/uri 'android'/'http://schemas.android.com/apk/res/android'
Name of the app is [_A_podeal]
Updating full app name to [_A_podeal]
Processing preference android-minSdkVersion [14]
Processing preference android-targetSdkVersion [23]
Processing preference android-installLocation [auto]
Processing preference permissions
Updating the versionCode
Updating the versionName
Processing debuggable
Added [{http://schemas.android.com/apk/res/android}debuggable] with [false]
Processing config file values
Saving config.xml to [.../_A_podeal/config.xml]
************* Completed processing the main config.xml file (after_prepare)  *****************
ANDROID_HOME=.../android-sdk
JAVA_HOME=/usr/lib/jvm/java-8-oracle-amd64
embedded
WARNING [Project: :] Current NDK support is deprecated.  Alternative will be provided in the future.
WARNING [Project: :] Current NDK support is deprecated.  Alternative will be provided in the future.
WARNING [Project: :] Current NDK support is deprecated.  Alternative will be provided in the future.
WARNING [Project: :] Current NDK support is deprecated.  Alternative will be provided in the future.
org.xwalk:xwalk_core_library:16+
:preBuild
:compileArmv7ReleaseNdk
:preArmv7ReleaseBuild
:checkArmv7ReleaseManifest
:preX86ReleaseBuild
:CordovaLib:compileLint
:CordovaLib:copyReleaseLint UP-TO-DATE
:CordovaLib:mergeReleaseProguardFiles
:CordovaLib:preBuild
:CordovaLib:preReleaseBuild
:CordovaLib:checkReleaseManifest
:CordovaLib:prepareReleaseDependencies
:CordovaLib:compileReleaseAidl
:CordovaLib:compileReleaseRenderscript
:CordovaLib:generateReleaseBuildConfig
:CordovaLib:generateReleaseAssets UP-TO-DATE
:CordovaLib:mergeReleaseAssets
:CordovaLib:generateReleaseResValues
:CordovaLib:generateReleaseResources
:CordovaLib:packageReleaseResources
:CordovaLib:processReleaseManifest
:CordovaLib:processReleaseResources
:CordovaLib:generateReleaseSources
:CordovaLib:compileReleaseJavaNote: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

:CordovaLib:processReleaseJavaRes UP-TO-DATE
:CordovaLib:packageReleaseJar
:CordovaLib:compileReleaseNdk
:CordovaLib:packageReleaseJniLibs UP-TO-DATE
:CordovaLib:packageReleaseLocalJar UP-TO-DATE
:CordovaLib:packageReleaseRenderscript UP-TO-DATE
:CordovaLib:bundleRelease
:com.appodeal.googleplayservices:google-play-services_lib:compileLint
:com.appodeal.googleplayservices:google-play-services_lib:copyReleaseLint UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:mergeReleaseProguardFiles
:com.appodeal.googleplayservices:google-play-services_lib:preBuild
:com.appodeal.googleplayservices:google-play-services_lib:preReleaseBuild
:com.appodeal.googleplayservices:google-play-services_lib:checkReleaseManifest
:com.appodeal.googleplayservices:google-play-services_lib:prepareAndroidCordovaLibUnspecifiedReleaseLibrary
:com.appodeal.googleplayservices:google-play-services_lib:prepareReleaseDependencies
:com.appodeal.googleplayservices:google-play-services_lib:compileReleaseAidl
:com.appodeal.googleplayservices:google-play-services_lib:compileReleaseRenderscript
:com.appodeal.googleplayservices:google-play-services_lib:generateReleaseBuildConfig
:com.appodeal.googleplayservices:google-play-services_lib:generateReleaseAssets UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:mergeReleaseAssets
:com.appodeal.googleplayservices:google-play-services_lib:generateReleaseResValues
:com.appodeal.googleplayservices:google-play-services_lib:generateReleaseResources
:com.appodeal.googleplayservices:google-play-services_lib:mergeReleaseResources
:com.appodeal.googleplayservices:google-play-services_lib:processReleaseManifest
:com.appodeal.googleplayservices:google-play-services_lib:processReleaseResources
:com.appodeal.googleplayservices:google-play-services_lib:generateReleaseSources
:com.appodeal.googleplayservices:google-play-services_lib:compileReleaseJava
:com.appodeal.googleplayservices:google-play-services_lib:processReleaseJavaRes UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:packageReleaseJar
:com.appodeal.googleplayservices:google-play-services_lib:compileReleaseNdk
:com.appodeal.googleplayservices:google-play-services_lib:packageReleaseJniLibs UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:packageReleaseLocalJar
:com.appodeal.googleplayservices:google-play-services_lib:packageReleaseRenderscript UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:packageReleaseResources
:com.appodeal.googleplayservices:google-play-services_lib:bundleRelease
:prepareAndroidComAppodealGoogleplayservicesGooglePlayServices_libUnspecifiedReleaseLibrary
:prepareAndroidCordovaLibUnspecifiedReleaseLibrary
:preArmv7DebugBuild
:preX86DebugBuild
:CordovaLib:copyDebugLint UP-TO-DATE
:CordovaLib:mergeDebugProguardFiles
:CordovaLib:preDebugBuild
:CordovaLib:checkDebugManifest
:CordovaLib:prepareDebugDependencies
:CordovaLib:compileDebugAidl
:CordovaLib:compileDebugRenderscript
:CordovaLib:generateDebugBuildConfig
:CordovaLib:generateDebugAssets UP-TO-DATE
:CordovaLib:mergeDebugAssets
:CordovaLib:generateDebugResValues
:CordovaLib:generateDebugResources
:CordovaLib:packageDebugResources
:CordovaLib:processDebugManifest
:CordovaLib:processDebugResources
:CordovaLib:generateDebugSources
:CordovaLib:compileDebugJavaNote: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

:CordovaLib:processDebugJavaRes UP-TO-DATE
:CordovaLib:packageDebugJar
:CordovaLib:compileDebugNdk
:CordovaLib:packageDebugJniLibs UP-TO-DATE
:CordovaLib:packageDebugLocalJar UP-TO-DATE
:CordovaLib:packageDebugRenderscript UP-TO-DATE
:CordovaLib:bundleDebug
:com.appodeal.googleplayservices:google-play-services_lib:copyDebugLint UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:mergeDebugProguardFiles
:com.appodeal.googleplayservices:google-play-services_lib:preDebugBuild
:com.appodeal.googleplayservices:google-play-services_lib:checkDebugManifest
:com.appodeal.googleplayservices:google-play-services_lib:preDebugTestBuild
:com.appodeal.googleplayservices:google-play-services_lib:prepareAndroidCordovaLibUnspecifiedDebugLibrary
:com.appodeal.googleplayservices:google-play-services_lib:prepareDebugDependencies
:com.appodeal.googleplayservices:google-play-services_lib:compileDebugAidl
:com.appodeal.googleplayservices:google-play-services_lib:compileDebugRenderscript
:com.appodeal.googleplayservices:google-play-services_lib:generateDebugBuildConfig
:com.appodeal.googleplayservices:google-play-services_lib:generateDebugAssets UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:mergeDebugAssets
:com.appodeal.googleplayservices:google-play-services_lib:generateDebugResValues
:com.appodeal.googleplayservices:google-play-services_lib:generateDebugResources
:com.appodeal.googleplayservices:google-play-services_lib:mergeDebugResources
:com.appodeal.googleplayservices:google-play-services_lib:processDebugManifest
:com.appodeal.googleplayservices:google-play-services_lib:processDebugResources
:com.appodeal.googleplayservices:google-play-services_lib:generateDebugSources
:com.appodeal.googleplayservices:google-play-services_lib:compileDebugJava
:com.appodeal.googleplayservices:google-play-services_lib:processDebugJavaRes UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:packageDebugJar
:com.appodeal.googleplayservices:google-play-services_lib:compileDebugNdk
:com.appodeal.googleplayservices:google-play-services_lib:packageDebugJniLibs UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:packageDebugLocalJar
:com.appodeal.googleplayservices:google-play-services_lib:packageDebugRenderscript UP-TO-DATE
:com.appodeal.googleplayservices:google-play-services_lib:packageDebugResources
:com.appodeal.googleplayservices:google-play-services_lib:bundleDebug
:prepareComAndroidSupportSupportV42400Alpha1Library
:prepareOrgXwalkXwalk_core_library164542119Library
:prepareArmv7ReleaseDependencies
:compileArmv7ReleaseAidl
:compileArmv7ReleaseRenderscript
:generateArmv7ReleaseBuildConfig
:generateArmv7ReleaseAssets UP-TO-DATE
:mergeArmv7ReleaseAssets
:createXwalkCommandLineFileArmv7Release
:generateArmv7ReleaseResValues
:generateArmv7ReleaseResources
:mergeArmv7ReleaseResources
:processArmv7ReleaseManifest
:processArmv7ReleaseResources
:generateArmv7ReleaseSources
:compileArmv7ReleaseJavaNote: .../_A_podeal/platforms/android/src/org/apache/cordova/splashscreen/SplashScreen.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

:preDexArmv7Release
:dexArmv7Release
UNEXPECTED TOP-LEVEL EXCEPTION:
com.android.dex.DexException: Multiple dex files define Landroid/support/annotation/AnimRes;
   at com.android.dx.merge.DexMerger.readSortableTypes(DexMerger.java:596)
   at com.android.dx.merge.DexMerger.getSortedTypes(DexMerger.java:554)
   at com.android.dx.merge.DexMerger.mergeClassDefs(DexMerger.java:535)
   at com.android.dx.merge.DexMerger.mergeDexes(DexMerger.java:171)
   at com.android.dx.merge.DexMerger.merge(DexMerger.java:189)
   at com.android.dx.command.dexer.Main.mergeLibraryDexBuffers(Main.java:454)
   at com.android.dx.command.dexer.Main.runMonoDex(Main.java:303)
   at com.android.dx.command.dexer.Main.run(Main.java:246)
   at com.android.dx.command.dexer.Main.main(Main.java:215)
   at com.android.dx.command.Main.main(Main.java:106)

 FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':dexArmv7Release'.
> com.android.ide.common.internal.LoggedErrorException: Failed to run command:
     .../android-sdk/build-tools/21.1.2/dx --dex --output .../_A_podeal/platforms/android/build/intermediates/dex/armv7/release --input-list=.../_A_podeal/platforms/android/build/intermediates/tmp/dex/armv7/release/inputList.txt
  Error Code:
     2
  Output:
     
     UNEXPECTED TOP-LEVEL EXCEPTION:
     com.android.dex.DexException: Multiple dex files define Landroid/support/annotation/AnimRes;
        at com.android.dx.merge.DexMerger.readSortableTypes(DexMerger.java:596)
        at com.android.dx.merge.DexMerger.getSortedTypes(DexMerger.java:554)
        at com.android.dx.merge.DexMerger.mergeClassDefs(DexMerger.java:535)
        at com.android.dx.merge.DexMerger.mergeDexes(DexMerger.java:171)
        at com.android.dx.merge.DexMerger.merge(DexMerger.java:189)
        at com.android.dx.command.dexer.Main.mergeLibraryDexBuffers(Main.java:454)
        at com.android.dx.command.dexer.Main.runMonoDex(Main.java:303)
        at com.android.dx.command.dexer.Main.run(Main.java:246)
        at com.android.dx.command.dexer.Main.main(Main.java:215)
        at com.android.dx.command.Main.main(Main.java:106)
     


* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 1 mins 50.693 secs
ERROR building one of the platforms: Error: .../_A_podeal/platforms/android/gradlew: Command failed with exit code 1
You may not have the required environment or OS to build this project
Error: .../_A_podeal/platforms/android/gradlew: Command failed with exit code 1
    at ChildProcess.whenDone (.../_A_podeal/platforms/android/cordova/node_modules/cordova-common/src/superspawn.js:139:23)
    at emitTwo (events.js:87:13)
    at ChildProcess.emit (events.js:172:7)
    at maybeClose (internal/child_process.js:821:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)
B
82
S
21
G
23
Posts: 520
Reputation: 18,737

Post » Tue Mar 29, 2016 5:40 am

i was having the same problem with appodeal now everything is sought out
error was coming when i try to build apk via crosswolk with android
you just try to build apk with android
use appodeal folder for plugins copy and paste to your project
import in xdk it will show some plugin type msg
just close xdk and restart try to build apk
it'll work
Image
B
68
S
40
G
48
Posts: 680
Reputation: 34,066

PreviousNext

Return to How do I....?

Who is online

Users browsing this forum: No registered users and 16 guests