How do I Get Background Music To Load Consistently?

Get help using Construct 2

Post » Fri Apr 29, 2016 10:35 pm

What is the recommended way to get background music to load consistently?

I have background music imported to the music folder. I tried loaded it on start layout, I also tried having preload of the music on load, then once preload is done to play the background music. In both scenarios, with edge, chrome, and windows phone the music does not always load. If I reload the continuously, it sometimes starts playing and othertimes does not.

Does anyone have any suggestions on making the background music load more stable?

If it helps, the background music is a constant loop of a 5 second clip.
B
43
S
18
G
8
Posts: 500
Reputation: 8,445

Post » Sat Apr 30, 2016 6:57 am

I tried loaded it on start layout, I also tried having preload of the music on load, then once preload is done to play the background music.


are you reloading music? actually, music should be loaded just once. If you load music again, i think it will flush out music data that has already been loaded and start over.

For streaming, if the Internet connection is bad, there are chances that music streaming will not be stable.

Since your music is just 5 seconds loop, I suggest putting this sound as sound effects instead. That way, this sound will be loaded as a whole and not as a stream. In addition, if you have "preload all sounds" on, you should be able to play this sound without any problem from now on. Unless C2 has trouble loading it up in the beginning because of unstable connection.

I believe C2 should keep on trying loading all the sounds listed as sound effects until all sounds are loaded. Only then, will the game start.
I got a game that you multiply, breath fire with two heads and brawl foes to oblivion with your clones: http://www.newgrounds.com/portal/view/660664 (use Chrome on Windows for best performance)

My sites:
http://twinblazar.deviantart.com
http://twinblazar.newgrounds.com
https://twitter.com/twinblazar
http://www.pixiv.net/member.php?id=15072448
B
30
S
11
G
11
Posts: 411
Reputation: 8,469

Post » Sat Apr 30, 2016 8:54 pm

Ill try switching it to a sound effect instead of music, thanks @keroberos.

as for connection. that cannot be it. 2 MS ping, plus running locally.
B
43
S
18
G
8
Posts: 500
Reputation: 8,445


Return to How do I....?

Who is online

Users browsing this forum: dop2000, uzumiapps and 31 guests