How do I get my fonts to display correctly?

Get help using Construct 2

Post » Tue Dec 20, 2016 11:09 pm

When I export to HTML5 the font style does not carryover. The game displays Ariel font instead of any font of my choosing.
B
39
S
18
G
5
Posts: 98
Reputation: 5,621

Post » Wed Dec 21, 2016 12:17 am

First of all, a bit more info would be useful.

  • Do you export to a server?
  • With which browser are you viewing the page?
  • Does it work in the preview?
  • Which font are you trying to export?

Also, a .capx is always helpful.

Without the .capx, I can't assume really much.
It might be the case that the font is not web-safe, but to tell, I'll have to know more about your project.
"We can't solve problems by using the same kind of thinking we used when we created them."
- Albert Einstein
B
27
S
11
G
8
Posts: 528
Reputation: 7,091

Post » Wed Dec 21, 2016 1:01 am

I am using Comic Sans MS.

I have exported to Bitballoon.com to run the HTML.
Firefox seems to work properly but the font placement is slightly shifted and does not display the same as it does in the preview.
My C2 preview browser is Chrome but running the exported file through Chrome and the bitballoon hosting site, it reverts to Ariel font.
B
39
S
18
G
5
Posts: 98
Reputation: 5,621

Post » Wed Dec 21, 2016 3:12 am

Again, I will need the .capx to see what's going on.
Or maybe at least a screenshot of the text properties and the text events in the event sheet, if any existing.

Maybe you are using a non-websafe font style.

Also, try to change Comic Sans to other web-safe fonts like Tahoma or Courier/Courier New and see what happens.
"We can't solve problems by using the same kind of thinking we used when we created them."
- Albert Einstein
B
27
S
11
G
8
Posts: 528
Reputation: 7,091


Return to How do I....?

Who is online

Users browsing this forum: bluesun66, plinkie and 3 guests