How do I get this on click event to work properly?

Get help using Construct 2

Post » Thu Jul 27, 2017 3:22 pm

Why do I have to click the start button several times on the start page ?

http://timesignature.co.uk/alphabet/index.html
B
17
S
6
G
1
Posts: 83
Reputation: 1,895

Post » Thu Jul 27, 2017 3:31 pm

It's hard to tell without seeing the capx. Maybe the page is still loading in the background? Perhaps switch to a different frame on the button when it's been clicked, at least that way you can tell whether it's because the button isn't registering or because there's a delay before loading the next layout after the click has been registered.
B
19
S
8
G
3
Posts: 425
Reputation: 3,968

Post » Fri Jul 28, 2017 7:31 am

Check the collision polygon shape of the button sprites. Maybe the "guessed" shape got mangled up and you need to shape it manually.
B
15
S
6
Posts: 85
Reputation: 1,195

Post » Fri Jul 28, 2017 3:34 pm

Thanks guys. I initially added a sound action to the click but it became quite annoying to have to click the button 3 times and still not going to the game. The collision poly is OK. The coding is a simple on object clicked??? Any more ideas???
B
17
S
6
G
1
Posts: 83
Reputation: 1,895

Post » Fri Jul 28, 2017 4:13 pm

if the button is definitely registering the click then try adding a loader layout and make sure all sounds are preloaded, rather than starting on the Home screen.
B
19
S
8
G
3
Posts: 425
Reputation: 3,968


Return to How do I....?

Who is online

Users browsing this forum: luckyrawatlucky, nahima and 8 guests