How do I Jump/Falling Animation

Get help using Construct 2

Post » Fri Oct 27, 2017 10:54 am

Message: JackTYGA can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
I have ran into a problem with my jumping and falling animation. For some reason it looks like its only playing one of the frames in my jump and falling animations, when i actually have around 7-8 frames.

This is what i have so far
https://imgur.com/a/8lVjI

The running animation works fine tho.

Can't seem to figure out why the animation isn't playing, any suggestions?

Thanks in advance :)
B
4
Posts: 44
Reputation: 296

Post » Fri Oct 27, 2017 11:03 am

You need to add "System->Trigger once" to your events 14, 16 and 17.
Otherwise they are triggered every tick and your animation is constantly restarted from the beginning.
Image

Did I help to fix a problem in your game? You can buy me a cup of coffee :) If you'd like to hire me, please see this post
B
17
S
9
G
127
Posts: 1,762
Reputation: 67,845

Post » Fri Oct 27, 2017 11:29 am

dop2000 wrote:You need to add "System->Trigger once" to your events 14, 16 and 17.
Otherwise they are triggered every tick and your animation is constantly restarted from the beginning.



How would I do this. I just tried adding below below system -> trigger once -> action // player -> set animation to jump (play from beginning) but that doesn't work.

Tried adding it on the action on the events you said but system -> trigger isn't on the actions bit.

Sorry fairly new to construct also!

Thanks!!
B
4
Posts: 44
Reputation: 296

Post » Fri Oct 27, 2017 11:38 am

Select the event and press C to add another condition.
Image
Image

Did I help to fix a problem in your game? You can buy me a cup of coffee :) If you'd like to hire me, please see this post
B
17
S
9
G
127
Posts: 1,762
Reputation: 67,845


Return to How do I....?

Who is online

Users browsing this forum: thomazette and 12 guests