How do I loop webm or h.264 videos seamlessly?

Get help using Construct 2

Post » Thu Mar 03, 2016 5:17 am

I have a video that I want to seamlessly loop. When I test the playback there is a tiny pause when it restarts.

As an example, if I had a video background of a tree and the branches move slightly, I want the video to loop seamlessly so the branches never stop moving.
B
5
S
1
Posts: 8
Reputation: 409

Post » Thu Mar 03, 2016 10:28 am

I'm looking for a solution to this problem as well, there are a lot of variables to take into account such as which browser you're testing on and which video format you're using. The way your video is encoded can also apparently have an effect on how well it loops - eg Chrome can screw up the looping MP4s if the keyframes set aren't evenly divisible within the length of the video. I'm only just getting into video with Construct but I can see the looping being an issue for me as well so will be conducting a bunch of tests.
B
64
S
25
G
4
Posts: 204
Reputation: 6,993

Post » Thu Mar 03, 2016 5:26 pm

Message: horoblast can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
https://www.scirra.com/manual/181/video maybe under Video => Video Actions => Set Looping ?
B
6
Posts: 50
Reputation: 367

Post » Fri Mar 04, 2016 4:27 am

Yeah, I have it setup that way. There is always a slight pause when the video loops again. I'm testing it with nw.js since that is my target publishing output. I'll keep testing different things.
B
5
S
1
Posts: 8
Reputation: 409


Return to How do I....?

Who is online

Users browsing this forum: Clark Thy Lord and 1 guest