How do I make two permanent crouching animations?

Get help using Construct 2

Post » Sun Apr 06, 2014 7:28 pm

Hi everyone, I'm new here. I just started messing around with Construct 2 and I have to admit it's a lot more simple than other programs I have used in the past. However, I've been running into some issues.

First of all, how would I go to make it so there are two permanent crouching animations?

This, basically:

When down arrow is pressed, the character goes into a permanent crouching state. It plays one frame of a standing to crouching pose then a 5-frame animation of a crouching animation.

When down arrow is pressed again, the character goes into another permanent crouching state but can now move around.

When up arrow is pressed once, it goes back to the first crouching state. When up arrow is pressed another time, it goes back to the standing state.

The closest I have managed to do is to make the character crouch when HOLDING the down arrow and not pressing it and even then, the animation isn't playing, just the first frame, nor is the standing to crouch pose.

Lastly, I seem to also have sound effect issues. The character can shoot bullets by either holding or pressing the S key, when held, it shoots slowly but when pressed, it can shoot faster. Not only does when I press it shoots at the same speed although I used a different value, but the sound effect gets cut as soon as I let go the button. If I hold it, it works fine, but if I just press it, it doesn't fully play. Another sound issue is that I have made a button to run faster than usual which works, but the sound of the footsteps don't get any faster.

Sorry for all the questions, but thanks in advance for the help! :)
B
3
Posts: 3
Reputation: 181

Post » Sun Apr 06, 2014 8:52 pm

Does the following capx come close enough to what you're after?

http://www.eli0s.com/Tests/CrouchingTest.capx

Use "A","D" to move left and right, "Space" to jump and "S","W" to toggle between crouching states.

Regarding the sound issues that you mention, I am not quite sure that I understand what you mean, but if I had to make an educated guess that would be that you are re-triggering the sound(s) at every frame (tick).
Ont he event that you want to trigger the sound from, create a sub event and add the System's "Trigger once while true" condition. Then put the play sound action.

Hope that helps ;)
composer - multimedia artist
www.eli0s.com/en/
B
69
S
27
G
6
Posts: 1,146
Reputation: 10,379

Post » Sun Apr 06, 2014 9:09 pm

That is exactly what I was looking for, thank you very much! I love how you made all of this just so I could understand it better, that's greatly appreciated. I'll get right into it and try to replicate this for my character.

As for the sound issues, I'll try to do what you said. Basically, when my character runs, there is a footstep sound effect that plays. I have a button that makes the character run faster and I'm trying to make it so the footstep sound is also faster, 1.5 times faster, precisely. As for the other issue, it's that when I press the shoot button, the bullet sound doesn't fully play, instead it just plays until I let go the button.

Edit: I partially managed to make it work, however when my character moves in the second crouching state, it does the standing running animation instead of the crouching one. Furthermore, both the two crouching states only play the first frame of their respective animation instead of looping. Lastly, when I press up to go back to the second crouching state, the character jumps. It doesn't jump when doing it again, though.

As for the sound, I seem to have the same issues as earlier. Would it be too much to ask if I could send you the file over Skype or something? Or show you some screenshots so you can better understand what the problem may be? Thanks again.
B
3
Posts: 3
Reputation: 181

Post » Sun Apr 06, 2014 10:08 pm

I don't mind giving it a shot but I don't use Skype very much. How big of a file is it, couldn't you send it with an e-mail?

Of course, if you post screenshots here on the forums, other users that are more knowledgeable than me might also help.

Anyway, my mail is [email protected], feel free to send a sample or something and I'll try to help!
composer - multimedia artist
www.eli0s.com/en/
B
69
S
27
G
6
Posts: 1,146
Reputation: 10,379

Post » Sun Apr 06, 2014 10:20 pm

It isn't a big file actually, so I did as you suggested and sent you an email with it, thanks.

I'll make sure to post screenshots if further problems occur. :)
B
3
Posts: 3
Reputation: 181

Post » Mon Apr 07, 2014 1:34 am

Ok, I got it, please check your inbox!
composer - multimedia artist
www.eli0s.com/en/
B
69
S
27
G
6
Posts: 1,146
Reputation: 10,379


Return to How do I....?

Who is online

Users browsing this forum: Baidu [Spider] and 11 guests