How do I Open a Capx.Autosave File?

Get help using Construct 2

Post » Fri Mar 14, 2014 5:02 pm

I have a new issue now :(. Last night I stopped working on the test.capx file from before and started my work from the swordthrow.capx file. However when i downloaded it from Firefox I opened it with construct 2 but I did not save it to my computer. I got a ton of work done and I saved a lot, but this morning when i went to open the file it was nowhere to be found. The only traces I could find of it was the .capx.autosave file in my temp folder. When I try to open that I get a message that says "Error Document Empty. The file maybe invalid. Try checking the file in a text editor (Projects are saved in XML format).", but the file isn't empty and I don't wish to redo multiple hours worth of work. Also, it does not seem that Scirra will allow me to post files with the .autosave extension. What is the point of an autosave function if you can't open the files? If anyone has any experience with this sort of problem, please share it with me. I would really appreciate it.
B
4
S
1
Posts: 26
Reputation: 402

Post » Fri Mar 14, 2014 5:09 pm

Make a copy of the autosave file and rename it to remove the word "autosave" so it should say WHATEVERYOURFILENAME.capx and it will open.
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Post » Fri Mar 14, 2014 5:16 pm

The name of the file is swordThrow.capx, but the file type is autosave. Renaming it doesn't seem to help
B
4
S
1
Posts: 26
Reputation: 402

Post » Fri Mar 14, 2014 5:19 pm

So it says swordThrow.capx.autosave right It is a .capx you have to remove the autosave extension and then direct C2 to the file. I know cause the same thing has happen to me numerous times. When you remove the autosave extension the icon will change to Construct 2 project folder icon.

Depending on you windows setting it would pop up asking if you want to change the extension. Say yes.
Last edited by PhoenixNightly on Fri Mar 14, 2014 5:27 pm, edited 1 time in total.
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Post » Fri Mar 14, 2014 5:27 pm

I'm not sure how to do that since it already says just .capx
You do not have the required permissions to view the files attached to this post.
B
4
S
1
Posts: 26
Reputation: 402

Post » Fri Mar 14, 2014 5:28 pm

Go to your folder that has the autosave and show me a snapshot. Depending on how you OS is setup it is not showing you the .autosave extension which you have to switch on for it to work.

EDIT::
This is how it look when you change an autosave file
Autosave.png
You do not have the required permissions to view the files attached to this post.
Last edited by PhoenixNightly on Fri Mar 14, 2014 5:34 pm, edited 1 time in total.
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Post » Fri Mar 14, 2014 5:31 pm

/
You do not have the required permissions to view the files attached to this post.
B
4
S
1
Posts: 26
Reputation: 402

Post » Fri Mar 14, 2014 5:36 pm

Yes you folder isn't setup to show extensions. As you see in my post above. You would have to go to the folder options and uncheck hide extensions so that you can see its actual full name. Also you can do the same for the backup also. Make a copy and change the extension. remove the backup part.
Last edited by PhoenixNightly on Fri Mar 14, 2014 5:39 pm, edited 1 time in total.
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Post » Fri Mar 14, 2014 5:37 pm

I think that you're right, under the file details i can see that it's name is SwordThrow.capx.autosave, I'm just not sure how to change it.

Sorry, I posted before I saw your new post. Is this option under folder properties? I can't find it
Last edited by DarkJokerr on Fri Mar 14, 2014 5:41 pm, edited 1 time in total.
B
4
S
1
Posts: 26
Reputation: 402

Post » Fri Mar 14, 2014 5:40 pm

If you click to rename it does it show you the full name with the autosave?? If so just remove it..Or make sure nothing is selected click on the 'Organize' button to the left and click "Folder and Search Options" On the View tab find "Hide extensions of known file types' and uncheck hit okay and you should be able to see it. Make a copy of the file right click->Rename->remove '.autosave'
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Next

Return to How do I....?

Who is online

Users browsing this forum: Fradno, grigrizljac, korbaach and 22 guests