How Do I Optimize for Windows 8

Get help using Construct 2

Post » Fri Feb 01, 2013 5:16 pm

Hello,

New User to Construct and I am in the process of learning it. My first project went well yesterday as I took the platform jumping endless project that comes with Construct and changed it a bit. Added some new graphics, some items to collect, and moving platforms. I was happy with the output but when I went to put it on Windows 8 I ran into an issue.

I am getting 60+ FPS in IE and Chrome on Windows 8 Pro on my machine but when I export to Windows 8 and run in debug/release mode i get a choppy 50 FPS that slowly degrades down to the 40's during gameplay.

I am in the process of redoing it completely from scratch and testing in Windows 8 as I implement each piece of logic but was wondering if anyone has any advice on what "generically" might be causing issues on windows 8 such as certain objects or types of code.

Thank you =)      

Here is the Game I worked on yesterday as the test project and I would hope it could run at 60FPS as a Windows 8 App on my machines here.   Platform Jumping Test
B
16
S
4
G
4
Posts: 23
Reputation: 3,937

Post » Fri May 17, 2013 12:03 am

Hello mmoDust,

I am unsure if my issue was the same as your's BUT I found the solution for my particular issue. For me, my game was choppy when I executed the app from within VS2012 for Windows 8. However, if I stopped the game in VS2012 and ran the game from the Start screen, it ran perfect.

I hope this helps.
B
2
G
2
Posts: 4
Reputation: 1,058

Post » Fri May 17, 2013 1:50 pm

Debug mode is slower because it includes all the debug checks for development. Try running it in Release mode or as @jwh1981 suggests, directly from the Start screen.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600


Return to How do I....?

Who is online

Users browsing this forum: mjj1990 and 6 guests