How do I play a video in an exported file?

Get help using Construct 2

Post » Fri Sep 11, 2015 10:53 pm

So, I can play videos when I Run them in a browser (however for some reason the videos don't play if they are too long). I have the Personal License version of Construct 2 and I exported my project to my computer to play the game without needing a browser. For some reason, the video doesn't play. Why does it work in a browser and not when exported? Do I have to do something different? Change a setting? How do I get videos to work when exported to Windows using NW.is? Any help is very much appreciated! :)
B
11
S
1
Posts: 27
Reputation: 583

Post » Sat Sep 12, 2015 7:35 am

What format are your videos in? Are you supporting more than one codec?

It appears from THIS article that whilst most browsers support the MP4 H.264 codec, chromium - which NW.js uses - does not.

The MP4 container format with the H.264 video codec and the AAC audio codec is natively supported by desktop/mobile Internet Explorer, Safari and Chrome, but Chromium and Opera do not support the format.


After a quick test, I verified that NW.js after export plays webm and ogg but not MP4 H.264.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
136
S
31
G
87
Posts: 5,498
Reputation: 60,282

Post » Sun Sep 13, 2015 7:21 pm

I actually figured out the same problem myself earlier this week. But thank you anyhow. I got the video to work when changing the video format to Webm and then exporting it. I find it bizarre that such a common and popular format (MP4 H.264) does not work in NW.js. I almost feel as though this information needs to be given on the scirra article "exporting desktop apps with node webkit." --> https://www.scirra.com/tutorials/1276/e ... ode-webkit
B
11
S
1
Posts: 27
Reputation: 583


Return to How do I....?

Who is online

Users browsing this forum: Google [Bot] and 13 guests