How do I play a video in Construct 2?

Get help using Construct 2

Post » Fri Aug 28, 2015 5:10 am

I plan to make a game with cut scenes. I read the video part of the manual already. My problem is, I can't seem to tell Construct what video to use. I created a video in the layout. I then imported an .mp4 file which is compatible. Then I added the event System --> On start of layout. Next I added the action Video --> Play. The strange this is, after clicking "done" a "Parameters for Video" didn't show up. Now, how on earth is it supposed to play a video if it wont let me tell it what video to play? I clicked "Run layout" and as expected, nothing happened. I just want to tell it what video I want it to play and get it to work upon starting the game. If anyone can answer this, please help! Thank you.
B
11
Posts: 27
Reputation: 433

Post » Fri Aug 28, 2015 7:01 am

@SebastianOs
SebastianOs wrote:I plan to make a game with cut scenes. I read the video part of the manual already. My problem is, I can't seem to tell Construct what video to use. I created a video in the layout. I then imported an .mp4 file which is compatible. Then I added the event System --> On start of layout. Next I added the action Video --> Play. The strange this is, after clicking "done" a "Parameters for Video" didn't show up. Now, how on earth is it supposed to play a video if it wont let me tell it what video to play? I clicked "Run layout" and as expected, nothing happened. I just want to tell it what video I want it to play and get it to work upon starting the game. If anyone can answer this, please help! Thank you.


Have you put the video's filename into the Video Objects property section? You don't add it through events.

So for instance, after importing a video into your project files called "myvideo1.mp4', you would then change the property firld of the Video Object that says 'H264 source' to "myvideo1.mp4" (no quotes).

Does this work?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
84
Posts: 5,388
Reputation: 58,458

Post » Fri Aug 28, 2015 5:55 pm

Thank you for replying. Yes, I did put the video's filename into the Video Objects property section. The video wont play when the game starts. Secondly, it seems that I should be able to 'program' the video to play at certain points, as implied by what I read in the video part of the manual. For instance, I want to make the cut scenes take place after each mission is complete in my game. That doesn't seem like hard 'programing' from the looks of your software. From what I read in the video manual, Construct should have the potential to do that. My game isn't really asking much, just to play videos during certain parts of the game. Any help would be much appreciated. By the way, I have the free version of the software. Do I need to buy the full version to do these things?
B
11
Posts: 27
Reputation: 433


Return to How do I....?

Who is online

Users browsing this forum: NN81, ultrafop and 31 guests