How do I play an animation with a single button press?

Get help using Construct 2

Post » Fri Apr 10, 2015 3:36 pm

Message: arrjayjee can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
I'm not sure if this is a bug or if I'm doing something wrong, but I can't get an animation to play through.

I have it set to trigger on pressing the Z key and to start the "StandingAttack" animation from the beginning. But the animation only plays while the button is held down. If I don't hold the button down, it will pause and hold on an animation frame.

Kind of hard to describe but you can see what I mean if you try it out.

EDIT: https://www.dropbox.com/s/9tcy7203p5n1csp/caves%20of%20auld.capx?dl=0 Here's a link to my .capx so you can see what's going on.
B
5
Posts: 36
Reputation: 397

Post » Fri Apr 10, 2015 3:52 pm

@arrjayjee

Strange, just looked at the .capx and it's not working for me either. I tried moving the action so that it's played when you press Z instead of when the variable is 1. Still not working.

Submit a bug report and see where it goes.
The moderators are corrupt and ban for no reason, especially that condescending neckbeard asshole Kyatric. The forums are filled with fanboys.
Banned User
B
22
S
7
G
1
Posts: 558
Reputation: 2,925

Post » Fri Apr 10, 2015 3:52 pm

Image

change to

Image
Image
B
60
S
23
G
7
Posts: 1,461
Reputation: 10,661

Post » Fri Apr 10, 2015 3:58 pm

Thank you very much korbaach, that's fixed it. :D
B
5
Posts: 36
Reputation: 397


Return to How do I....?

Who is online

Users browsing this forum: khelaghor, SnipG and 9 guests